Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 377541 - Filters will not apply tags to new mail when "allow antivirus clients to quarantine individual messages" is enabled.
: Filters will not apply tags to new mail when "allow antivirus clients to quar...
Status: RESOLVED DUPLICATE of bug 355537
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- major with 11 votes (vote)
: ---
Assigned To: David :Bienvenu
Depends on:
  Show dependency treegraph
Reported: 2007-04-14 23:09 PDT by Benjamin Duranske
Modified: 2007-05-10 06:34 PDT (History)
12 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Benjamin Duranske 2007-04-14 23:09:41 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20070309 Firefox/
Build Identifier: Version 3.0a1 (20070414)  (ALSO TESTED ON TB2 Release Candidate 1 - version (20070326))

Filters will not automatically pply tags to new mail when the "allow antivirus clients to quarantine individual messages" option is enabled in Privacy/Antivirus (though manually running same filter does apply tag).

This is discussed in other tangents of other bug report threads, but none clearly describe the problem or point out the antivirus client option interaction.  Anyone should feel free to merge or cross-reference.

Reproducible: Always

Steps to Reproduce:
1. Create filter that applies "Important" tag to all mail from
2. Enable "allow antivirus clients to quarantine individual messages" option.
3. Send mail to account from
Actual Results:  
Filter fails to automatically apply "Important" tag to new mail from  (Note, however, that manually running the same filter after mail arrived does apply tag).

Expected Results:  
Filter should apply "Important" tag to new mail from

Tested on TB2 RC1 and tonight's nightly build.
Comment 1 David :Bienvenu 2007-04-15 08:57:18 PDT
confirming, not because I've reproduced it, but because it's quite plausible.
Comment 2 Daniel Tschinder 2007-04-18 11:37:28 PDT
Also reproduced that.

Version (20070326)
Comment 3 Alessandro Fernandes Martins 2007-04-26 04:25:33 PDT
Also reproduced that too.

Version (20070326)
Comment 4 kaspou 2007-04-26 10:15:02 PDT
Reproduced that too.
The bug is connected with the "allow antivirus
clients to quarantine individual messages" option.

Version (20070309)
Comment 5 kaspou 2007-04-26 10:16:41 PDT
I forgot to add a precision :

 - the filter is applied on another in the inbox (instead of being applied on the mail on which the filter was launched).
Comment 6 ALorber 2007-04-28 14:57:22 PDT
Version 1.8.20070.32620
Comment 7 David A. Cobb 2007-04-30 15:41:55 PDT
I can confirm, at least, that the sensitivity to the "allow antivirus clients" preference also occurs in
This should be tested as a possible dupe of Bug#355537.
Comment 8 David :Bienvenu 2007-04-30 15:43:23 PDT
please try tomorrow's 2.0 nightly branch build - it should be fixed in that build. resolving as dup

*** This bug has been marked as a duplicate of bug 355537 ***

Note You need to log in before you can comment on or make changes to this bug.