bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

(win32) menulist in a <window align="vertical"> has 0 height.

VERIFIED FIXED in M16

Status

()

Core
XUL
P1
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Donnie Cranford, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({pp, regression, smoketest})

Trunk
x86
All
pp, regression, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m16) Gecko/20000501
BuildID:    2000050111

Anytime you try to open anything you cannot pick it, it is simply a thin black
line.

Reproducible: Always
Steps to Reproduce:
1.file-open_weblocation
2.file-open
3.

Expected Results:  given you a choice....browser, composer
Confirming, adding keywords. The drop down list boxes are broken all over the 
chrome.

Gerv
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, smoketest
Trying XP Toolkit/Widgets.

Gerv
Assignee: asadotzler → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: jelwell → jrgm
*** Bug 37752 has been marked as a duplicate of this bug. ***
is this limited to Windows? i was unable to repro this --at least with the Open
Web Location dialog-- on linux or mac.

adding pp keyword --remove it if anyone has seen this elsewhere on a non-windows
platform. thx!
Keywords: pp

Comment 5

19 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]

Comment 6

19 years ago
<?xml version="1.0"?> 
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?> 
 
<window xmlns:html="http://www.w3.org/TR/REC-html40"
        xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
        align="vertical"> 

    <html:div>the black line below is a menulist on win32 2000050111 if the 
              window is align="vertical" (or orient="vertical"). Works on mac
              and linux.
    </html:div>

        <menulist>
          <menupopup>
            <menuitem data="0" value="topWindow label"/>
            <menuitem data="1" value="newWindow label"/>
          </menupopup>
        </menulist>

</window>
Summary: Pickers are broken → (win32) menulist in a <window align="vertical"> has 0 height.

Comment 7

19 years ago
Created attachment 8178 [details]
testcase; menulist in <window align="vertical">  (text/xul)
*** Bug 37927 has been marked as a duplicate of this bug. ***

Comment 9

19 years ago
reassigning to ben for possible style rule problem
Assignee: trudelle → ben
WORKSFORME (including testcase) on 20000507.

Gerv
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
... and doesn't work again in win32 2000050808 comm. build. (but for a while
this was fixed).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
It's fine in the moz.org 20000909 Windows bits, BTW.

Gerv
verrry interesting. on a related note, blake didn't have this problem either
while verifying bug 33361. wonder why this is nscp only now... adding nsonly
kw...but if it crops up again in mozilla, do remove it!
Keywords: nsonly

Comment 14

18 years ago
heh ... and not fine in 2000050908 win95 (missing a checkin? build config?)

Comment 15

18 years ago
Ben -- the file 'chrome/menulistBindings.xml' is missing from the
commercial win32 builds, which pretty much resolves this bug -- just
need to that manifest thing.

Comment 16

18 years ago
*** Bug 38802 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
I see it with 2000-05-10-12 on Linux, with the "choose internet keywords"
pull down list next to the URL bar. When clicked, only a thin vertical black
line appears.
Digging up older builds... I also see it with 2000-05-06-08 on Linux.

Tentatively changing OS to All.
OS: Windows NT → All

Updated

18 years ago
Keywords: nsbeta2
Priority: P3 → P1
Target Milestone: --- → M16
fixed.  we were not packaging menulistBindings.xml
Assignee: ben → sspitzer
Status: REOPENED → NEW
marking fixed, adding ben back to the cc list.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
verified fixed -- menulistbindings.xml is now packaged into the commercial win32 
builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.