Unhidden link anchors do not receive focus from keyboard

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: bhawkeslewis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a4pre) Gecko/20070415 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a4pre) Gecko/20070415 Minefield/3.0a4pre

With a DHTML menu, a sublist of links is set to display:none. When the user tabs to the sublist's name in the upper list, the sublist is set to display:block. But whereas in Firefox 2, the links in the sublist are then in the taborder, in the current Minefield it is impossible to tab to the links in the sublist. See attached testcase for an example. Unless I'm mistaken, this is a serious accessibility regression.

Reproducible: Always

Steps to Reproduce:
1. Open the testcase.
2. Tab with the keyboard to A-Z.
3. Try to tab to the first link in the sublist ("Skip A-Z").
Actual Results:  
Cannot tab to "Skip A-Z".

Expected Results:  
Can tab to "Skip A-Z".
(Reporter)

Comment 1

12 years ago
Okay, there doesn't seem to be a regression here. The problem was that blur events within the sublist were bubbling up and being caught, triggering hiding of the sublist. So a solution is to cancel that bubbling.

See: http://www.benjaminhawkeslewis.com/www/bugreports/mozilla/dropdown-solved.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.