Closed Bug 377662 Opened 13 years ago Closed 13 years ago

Message compose window does not open

Categories

(Thunderbird :: Message Compose Window, defect, blocker)

x86
Windows XP
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mozilla.b2w, Assigned: philor)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.2) Gecko/20070215 Firefox/2.0.0.2
Build Identifier: 2004041603  (3.0 pre)

When seeking to create a new message (eg from "write" or from the address book) I get the message:  "An error occurred while creating a message compose window.  Please try again."

Reproducible: Always

Steps to Reproduce:
1.Click "write"
2.
3.
See this starting with today's trunk on WinXP also.
Severity: major → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Version: unspecified → Trunk
Reporter:  did you typo your build id? :P
Confirming Build ID
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070416 Thunderbird/3.0a1 ID:2007041603 [cairo]
We need to figure out when this regressed so we can start blaming people.
Keywords: regression
Between 20070415 and 20070416 trunk.
Yesterday's checkin to mozilla/mailnews/compose/src/nsSmtpService.cpp?
Sounds possible. Ryan, beisi?

Are you guys using the installer or the zip build?
Im seeing this in a zip build.
that checkin (Bug 229168) shouldn't have an effect on this... only webbrowserpersist looks at that flag, and that's not involved here.

Jerry, what time was your 20070415 build from?
I don't know. It was whatever one was sent out over the automatic update.
(In reply to comment #7)
> Are you guys using the installer or the zip build?

In my case it's the installer build, obtained via automated update, not being able to open the composer window.
I have this problem with automated update too, updated from 0415 to 0416. Reverted back to 0415 build
Confirmed in the latest trunk version asswel:
version 3.0a1 (20070416)
P.s. Everyone vote for this bug to let people fix it.
(In reply to comment #7)
> Are you guys using the installer or the zip build?

Windows installer. as reported in 377727, which is a dup of this one...
Duplicate of this bug: 377727
I use the zip build. Just unpacked it in a fresh directory.
Dup of #203555?
(In reply to comment #18)
> Dup of #203555?

If at all (which I doubt), it would be a regression.

It's still there in 20070417-3
Warning: Key event not available on GTK2: key="a" modifiers="accel, shift"
Source File: chrome://messenger/content/messengercompose/messengercompose.xul
Line: 0

I see this error in JS console, repeated four times, when I do ctrl-shift-R to reply all to a message.

clicking on that chrome: link brings up an empty source window.

I also see the same error in the log, for keys "f" and "c", but I'm not sure exactly when they show up.
We really need someone with a debug build to figure out what's going on here...
Did an update to todays build.
version 3.0a1 (20070417)

Message Compose error is still there.
Hmm, a debug trunk build from about an hour ago doesn't show the problem for me.
I haven't seen this problem on the mac or windows with debug trunk builds.
There is something more sinister going on. I began crashing in Thunderbird yesterday for the first time in ages. It would just crash while sitting idle (biff?). The coincidence with this issue may not be so much a coincidence. I just crashed again while idle in my 20070415 build which is bad news ... it may mean the regression window is earlier than thought.

TB31282356E
TB31253788Z
TB31243273Q
According to a Talkback search, this crash started happening to people with the 2007041503 trunk build, and there have been 112 reports of it in the last two days ... nothing prior. If it is related, the regression window may be 20070414-20070415. Many of the reporters indicate that Thunderbird was idle at the time of the crash.
I have been running into a crash in the gecko tooltip code on the trunk, when I mouse over the reply/forward/write button...
For me the critical update was from 2007041503 -> 2007041603.
2007041503 worked fine, but when i updated to 2007041603 i was unable to
send/reply/forward messages. same is for current build 2007041703
Tooltip crash in 2007041503 would be bug 377473, fixed just after that nightly.

http://ln-s.net/QIP is the regression range (which with a quick look certainly doesn't seem like it would including anything non-debug-only), if someone wants to start backing things out one by one.
Duplicate of this bug: 377804
(In reply to comment #29)
> For me the critical update was from 2007041503 -> 2007041603.
> 2007041503 worked fine, but when i updated to 2007041603 i was unable to
> send/reply/forward messages. same is for current build 2007041703

Absolutely right.
I think someone started mixing two different bugs into this report.
too bad no compose test on tinderbox build 
Maybe we weren't quite as ready for bug 376205 as we thought? First, in the error console,

"""
Warning: reference to undefined property Components.interfaces.mozISpellCheckingEngine
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 14
"""

Then (with dump.enabled and -console, since compose startup errors are in a try-catch-dump()) in the console,

"""
Element  not found in SetElementEnabled
EX: = [Exception... "Invalid InterfaceID"  nsresult: "0x80570018 (NS_ERROR_XPC_B
AD_IID)"  location: "JS frame :: chrome://messenger/content/messengercompose/Msg
ComposeCommands.js :: InitLanguageMenu :: line 2144"  data: no]

ComposeUnload from XUL
"""
Blocks: 376205
And the fact that it's a compose failure, instead of just a spellcheck failure, looks to be because we didn't port bug 370891 yet.
Attached patch FixSplinter Review
Assignee: mscott → philringnalda
Status: NEW → ASSIGNED
Attachment #261927 - Flags: review?(mscott)
I just upgraded to the version 3.0a1 (20070417) and now the error pop-up is gone
and instead Thunderbird crashes on every attempt to compose, reply or forward a
message.
Comment on attachment 261927 [details] [diff] [review]
Fix

>+; spellchecker (may not be present)
>+bin\components\spellchecker.xpt
>+

Phil, why don't we just port the fix from bug 370891 instead of adding this bandaid-fix?
I can confirm this error in yesterday and today's build.  

version 3.0a1 (20070418)

I have attempted to uninstall and reinstall the latest build, and the problem still occurs.
version 3.0a1 (20070418)

Message on compose or reply still occurs for me as well.
(In reply to comment #38)
> Phil, why don't we just port the fix from bug 370891 instead of adding this
> bandaid-fix?

It's the other way around: porting bug 370891 is a bandaid that allows you to get in to a compose window with broken spellcheck UI (the button does nothing, its dropdown is a 4px square menu), while this *is* the fix.

I need to do something about the combination of bug 370891 and bug 318030, too, but that's not the blocker that this is.

version 3.0a1 (20070418)

************
Message Compose
An error occurred while creating a message compose windos.  Please try again.
OK
************

still occurs
Comment on attachment 261927 [details] [diff] [review]
Fix

thanks Phil.
Attachment #261927 - Flags: review?(mscott) → review+
mail/installer/windows/packages-static 1.46
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
OS: All → Windows XP
Resolution: --- → FIXED
Confirmed fix with the latest hourly :)

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a4pre) Gecko/20070418 Thunderbird/3.0a1 ID:2007041817 [cairo]
(In reply to comment #45)
> Confirmed fix with the latest hourly :)

I cannot confirm the FIX for the latest nightly.
(In reply to comment #46)
> I cannot confirm the FIX for the latest nightly.
> 

It's probably because the fix checked in after the 0418 nightly was released. It should work for the next nightly (0419)

Ok, thanks, Mike
Out of interest, how did this happen? You'd think that something as fundamental as being able to compose a message would be tested before code is allowed to be committed.
I was getting random crashes without opportunity to use Talkback, while composing mail (usually well through my composition) on Thunderbird nightly yesterday and the day before (probably the 16th's and 17th's versions).  I was using it through a network, which I hadn't previously done much, but given the problems others have been having it probably had nothing to do with the network, especially as my wife has been using Thunderbird (non-alpha, non-Beta) through our network without problems in the past.

I've reverted to an earlier version of TB 3 alpha 1 (maybe 30th March if I remember aright), and won't be allowing nightly upgrades until this bug is reported fixed.
Win 32 version 3.0a1 (20070418) [Hourly] - Fixed confirmed
(In reply to comment #50)
> I was getting random crashes without opportunity to use Talkback, while
> composing mail (usually well through my composition) on Thunderbird nightly
> yesterday and the day before (probably the 16th's and 17th's versions).  I was
> using it through a network, which I hadn't previously done much, but given the
> problems others have been having it probably had nothing to do with the
> network, especially as my wife has been using Thunderbird (non-alpha, non-Beta)
> through our network without problems in the past.
> 
I had random crashes with 0415 build. It usually happened when Thunderbird had been running for more than an hour and when I was deleting messages or reading other messages. But so far with the hourly version 041817, I haven't had one crash (Thunderbird has been running for 7 hours)

> I've reverted to an earlier version of TB 3 alpha 1 (maybe 30th March if I
> remember aright), and won't be allowing nightly upgrades until this bug is
> reported fixed.
> 
This bug is fixed with 041817 hourly version and should be fixed with 0419 nightly build.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a4pre) Gecko/20070418 Thunderbird/3.0a1 ID:2007041817 [cairo]

Marking as VERIFIED based on previous comments.

Guys, if you're seeing other issues on the trunk (e.g. crashes) please report them in other bugs (if they're not already filed) with appropriate information, steps to reproduce, etc. Commenting here is not making any progress toward getting those bugs fixed.

Graham, you bring up a good point. To answer your question, I would assume that Simon only tested his fix on Firefox (since the fix was almost the same for both Firefox and Thunderbird). I do agree that the compose window should've been tested, as it depends on the spellchecker.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.