Download counts show significatly lower numbers in Remora?

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Adam Kowalczyk, Assigned: morgamic)

Tracking

Details

(Reporter)

Description

11 years ago
I have seen a serious drop in the number of downloads of my extension since the download counts were turned on again (bug 375278). This of course may have been a coincidence but recently I have seen at least one other report about it (bug 371836 comment 3). I'm filing this bug to investigate if the download counts indeed show incorrect numbers.

Comment 1

11 years ago
I didn't see a drop for Adblock Plus, however download numbers for Element
Hiding Helper dropped by 50% as well. Reason might be that extensions not in
the Top 10 (?) are harder to find in the new interface. I think bug 371836
should be fixed ASAP because it is very hard to interpret download numbers if
you cannot compare.

Comment 2

11 years ago
I wonder if users just aren't visiting AMO like they used to.  The more users that visit, the more comments/reviews are posted.  My extensions used to get a few comments per week on average but since Remora, one extension has received only two comments and the others haven't gotten any at all.  In fact, as of this writing, the top 5 most popular FX extensions have managed to garner only 44 reviews betwixt them.  And this is probably over the course of many thousands of downloads.  (Of course, I can only guess at the number since the download counts are *still* not public ...)

Comment 3

11 years ago
It looks like the download counts have stopped moving again.

Comment 4

11 years ago
I reopened bug 375278.
(Assignee)

Comment 5

11 years ago
Shouldn't this depend on bug 375278 not block it?
No longer blocks: 375278
Status: UNCONFIRMED → NEW
Depends on: 375278
Ever confirmed: true
(Assignee)

Comment 6

11 years ago
Counts are going again, let's wait a week to see how things go.  In the meantime we should have discussion on potential causes for the dropoff.
Assignee: nobody → morgamic
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 7

11 years ago
That's difficult if one only has two-three samples. The numbers for AMO from before the switch to Remora are there, it would be nice to see the current numbers at least for the first 30 extensions for comparison.

Comment 8

11 years ago
I am not sure if the dropoff is a bug: I remember Sancus implementing logic in order to avoid multiple counts of the same download. If AMOv2 did not have this logic but suffered from the same issue, then Remora would have fixed a bug here, not implemented one.

Sancus, can you confirm what the issue was? Morgamic, can you tell us how AMOv2 counted?

Comment 9

11 years ago
Sorry I do not agree : one of my extensions asks users for an optional registration. 
Just since the week Remora is out, I have half registrations I used to have, and Developer Page shows half download counts as well, which is very consistent (I'm talking about 4 digit numbers each day, so that's pretty reliable I think).

Comment 10

11 years ago
AMOv2 would not count a download from the same IP within 10 minutes. Looking at Remora code now - it uses cookies to achieve the same. However, the cookie only has 10 *seconds* expiration time, looks like a bug to me. So this should result in higher download numbers if anything. Even the correct implementation should overestimate download numbers (cookies disabled, skewed clocks). Only issue: the cookie is not dependent on the extension causing downloads of *different* extensions within this 10 minutes interval not being counted.

Comment 11

11 years ago
Wladimir, I really do not think the download count is wrong, it appears to be right (see comment #9) but just half what it used to be.
A faulty cookie would not be the cause of this.

Comment 12

11 years ago
Xavier, that was exactly my point - differences in counting couldn't have caused this effect, it must be something else. I filed bug 380377 on the flaws in the download counter implementation, it has nothing to do with this bug.

Comment 13

11 years ago
oops okay sorry I was misled by your last sentence about downloading different extensions being counted as only one download. I got it now, thanks.
Downloads are definitely down for some add-ons, independent of whatever issues there might be with the counting mechanism, and we're looking into what has changed in the traffic patterns.
(I should add that aggregate user visits are way up.)
(Reporter)

Comment 16

11 years ago
(In reply to comment #14)
> Downloads are definitely down for some add-ons, independent of whatever issues
> there might be with the counting mechanism, and we're looking into what has
> changed in the traffic patterns.

The most obvious explanation would be that the new categorization and the new search engine changed the discoverability patterns. The question is: did some add-ons gain as much downloads as the others had lost? The change wasn't necessarily for the worse as long as the cumulative download counts didn't drop. It's always worth investigating how and why the traffic patterns have changed.

Bug 375809 is an example of what could have affected discoverability of various add-ons. Sorting by rating when searching when looking for add-ons is probably quite common. Now, if my extension has an average rating of 4.60 (which used to be pretty high on 5-grade scale) instead of 9.20 it sure affected its position in search results.

Comment 17

11 years ago
But keep in mind another aspect pointer by Chuck in comment #2 :

"as of this writing, the top 5 most popular FX extensions have managed to garner only 44 reviews betwixt them.  And this is probably over the course of many
thousands of downloads."
Looks like popular extensions are still popular, but getting lesser visits.
And he wonders if people are still visiting AMO as they used to ?

Is there some global data available on the site audience ?

As for me, I noticed that Remora is (still) considerably slower than AMOv2. 
Could that be part of an explanation ?
(In reply to comment #17)
> But keep in mind another aspect pointer by Chuck in comment #2 :
> 
> "as of this writing, the top 5 most popular FX extensions have managed to
> garner only 44 reviews betwixt them.  And this is probably over the course of
> many
> thousands of downloads."
> Looks like popular extensions are still popular, but getting lesser visits.

Not to me.  Looks like there's a huge backlog of reviews in the moderation queue.

> And he wonders if people are still visiting AMO as they used to ?

Total site visits are up since Remora launched, in fact, and new user account creation is through the roof.

> Is there some global data available on the site audience ?

Not reliable, unfortunately, which is what I'm spending a bunch of time on over the past few days.

> As for me, I noticed that Remora is (still) considerably slower than AMOv2. 
> Could that be part of an explanation ?

If it is, it's a separate bug in need of much more detail.

This discussion is getting quite far afield of the topic of this bug: displayed download counts being lower than pre-Remora.  If there are other issues that people feel should be remedied, they should please file other bugs on the topics in question; wide-ranging discussions make it harder to fix specific issues.

Comment 19

11 years ago
(In reply to comment #16)
> The question is: did some
> add-ons gain as much downloads as the others had lost?

I think so. If I look at Adblock Plus now, it is usually around 200k downloads weekly whereas it was 150k in AMOv2. A partial reason might be that the downloads from the Adblock Plus homepage and downloads of old versions are counted now, but there is still certainly a significant increase of regular downloads. I suspect that other recommended add-ons have seen similar increases since they are very discoverable.

Comment 20

11 years ago
(In reply to comment #2)
> I wonder if users just aren't visiting AMO like they used to.  The more users
> that visit, the more comments/reviews are posted.  My extensions used to get a
> few comments per week on average but since Remora, one extension has received
> only two comments and the others haven't gotten any at all.  In fact, as of
> this writing, the top 5 most popular FX extensions have managed to garner only
> 44 reviews betwixt them.  And this is probably over the course of many
> thousands of downloads.  (Of course, I can only guess at the number since the
> download counts are *still* not public ...)
> 
While the download counts for my four extensions seems to have stabilized now in Remora, the number of comments/reviews has virtually stopped. Since my last post on this topic, my combined downloads were ~45,000 - 50,000 but only *one* review was posted.  With AMOv2, I would have seen dozens of reviews over the same period.

I don't think it's just me.  A random sampling of other popular extensions seems to indicate a smaller number of reviews since Remora.
(In reply to comment #20)
> While the download counts for my four extensions seems to have stabilized now
> in Remora, the number of comments/reviews has virtually stopped. Since my last
> post on this topic, my combined downloads were ~45,000 - 50,000 but only *one*
> review was posted.

Chuck: comment 18 (review queue) still applies, but it's very high on the priority list to remedy this.

Comment 22

11 years ago
For the past 2 days, it seems that the install counter for the week has stopped counting new installs, while the total counter is still running normally.

In 2 days, my week counter dropped from 28,000 to 19,000 while i don't see any slow down in my extension usage and during this period the overall counter increased from 800,000 to 810,000. Also, i must add that the downloads for my extension have been very stable for the last 7-8 weeks.

Comment 23

11 years ago
It seems the download count is acting up again, both my extensions show 1 download in the week slot.
I'm resolving this. Although there are still complaints about lower download numbers, those are since the implementation of the new download counter script, not Remora. bug 402796 is the new "download counts are too low" bug, so please post further comments there.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.