form field contains the wrong information

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: tfulker88, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.9a4pre) Gecko/20070417 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.9a4pre) Gecko/20070417 Camino/1.2+

When I go to the setup page for an Airlink 101 router, the display for the Username and password for the PPPOE form window is displaying the administration username and password instead of the PPPOE usernam and password. It only occurs in Camino. Firefox and Safari display correctly on the same computer. I'll past the source for the page at the attachment prompt.

Reproducible: Always

Steps to Reproduce:
1.Load the page. It is the first page when talking to the router.
2.
3.
(Reporter)

Comment 1

12 years ago
Created attachment 261851 [details]
source page that shows wrong info.

Thank you to all who work on these great programs.

Comment 2

12 years ago
I've locked down the attachment, as it appeared to contain an actual password. Please scrub sensitive information from attachments, as they are viewable by anyone visiting bugzilla.

Is the name and password being filled here something that you stored in the keychain for another page on the same domain?

Comment 3

12 years ago
(In reply to comment #2)

> Is the name and password being filled here something that you stored in the
> keychain for another page on the same domain?

While I don't have any experience with Airlink routers, I can almost guarantee this is exactly what's happening, as I've seen this sort of thing happen many times with other brands of routers. As such, this is a dupe of bug 178607 (I think that's the right bug).

cl

Comment 4

12 years ago
Hm, this is actually being filled by JS. Probably we filled something
overzealously, and now it's stored that information somewhere and is now
filling on its own. Without being able to interact with one of these systems
I'm not sure how we can figure how it got into this state...

Comment 5

12 years ago
I'm closing this as INVALID, although that's not really ideal. Per email, this was a password stored somewhere else on the same host. Somehow, it got to the point that the page itself was storing (possibly via cookie) and filling this password via JS; the behavior on the attached page has nothing to do with Camino's autofill. We probably started the ball rolling earlier, but without being able to explore one of these routers there's no real way for us to find out if what we filled was reasonable (it was on the same host, so it may well have been) or how that turned into something that's being filled separate from Camino's autofill.

To fix the case you are now in, I'd suggest removing your cookies for that host, since it seems likely that it's being stored there if you don't see this in other browsers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.