Firefox fails to open a local file that has a non-English name

RESOLVED DUPLICATE of bug 263570

Status

()

RESOLVED DUPLICATE of bug 263570
12 years ago
12 years ago

People

(Reporter: xxi_xxl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

When I try to open a file by double clicking it in Windows Explorer Firefox tells me that:

File not found
Firefox can't find the file at /D:/???.htm.

the name of the file is: "تست.htm"
The URL bar show: "file:///D:/%3F%3F%3F.htm"
but when I correct the path in the URL bar or when I use the Open dialogue it opens the file and shows the correct URL which is:
"file:///D:/%D8%AA%D8%B3%D8%AA.htm"

BTW IE opens it correctly.

Reproducible: Always

Steps to Reproduce:
1. create a file with non-English name. (in my case Persian)
2. double click the file in Windows Explorer.
Actual Results:  
FF won't open the file.

Expected Results:  
It should have opened the file.
(Reporter)

Comment 1

12 years ago
more info:
1. an English named file in a path that contains a non-English directory also does not open. The URL bar shows this:
"file:///D:/%3F%3F%3F/test.htm"

2. Windows does not allow "?" to be in the name of files and folders.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263570
You need to log in before you can comment on or make changes to this bug.