VersionCheck.php does not return latest update for extension 3130

RESOLVED DUPLICATE of bug 375023

Status

addons.mozilla.org Graveyard
Administration
--
major
RESOLVED DUPLICATE of bug 375023
11 years ago
2 years ago

People

(Reporter: Sébastien Vauclair, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: 

Firefox cannot find update 1.3 for this extension, it always finds update 1.2 (which was the last pre-Remora update).

Reproducible: Always

Steps to Reproduce:
1. Install version 1.2 of the extension (https://addons.mozilla.org/en-US/firefox/addon/3130)
2. Restart Firefox
3. Find update for extension
Actual Results:  
No update found

Expected Results:  
Version 1.3 found

Firefox requests URL:
https://addons.mozilla.org/update/VersionCheck.php?reqVersion=1&id={14d1580a-2611-11db-9628-00e08161165f}&version=1.2&maxAppVersion=2.0.0.*&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=1.5.0.11&appOS=WINNT&appABI=x86-msvc

Which indeed returns version 1.2, wherease version 1.3 exists (see https://addons.mozilla.org/en-US/firefox/addon/3130)

Additional testing done: installing v1.1.2 of the extension and checking for update finds v1.2

Comment 1

11 years ago
Note version 1.3 of this extension is showing a target minimum version of 1.5b1 which wasn't possible until recently.

Probably duplicate of bug 375023

Assuming this is your extension, try resetting the target version back to 1.5 - bug 375023 comment #12.
(Reporter)

Comment 2

11 years ago
Thanks John, that was exactly the problem, and your suggestion fixed it.
Marking as a duplicate of bug 375023
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375023
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.