Last Comment Bug 377867 - Range with no end attribute results in unusable control
: Range with no end attribute results in unusable control
Status: RESOLVED FIXED
: fixed1.8.0.12, fixed1.8.1.4
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: aaronr
: Stephen Pride
:
Mentors:
http://www.w3.org/MarkUp/Forms/Test/X...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 06:08 PDT by Steve Speicher
Modified: 2016-07-15 14:46 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
test case, 2 ranges with no ends (1.74 KB, application/xhtml+xml)
2007-04-18 06:09 PDT, Steve Speicher
no flags Details
patch (3.15 KB, patch)
2007-04-18 15:02 PDT, aaronr
aaronr: review+
surkov.alexander: review+
Details | Diff | Splinter Review

Description Steve Speicher 2007-04-18 06:08:08 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070416 Minefield/3.0a4pre
Build Identifier: 

This was working at some point, see bug 331987

This fails W3C Test Suite cases 8.1.7.a and 8.1.7.c

Reproducible: Always
Comment 1 Steve Speicher 2007-04-18 06:09:35 PDT
Created attachment 261936 [details]
test case, 2 ranges with no ends
Comment 2 aaronr 2007-04-18 15:01:16 PDT
problem was that we assumed slider's getXCoordFromValue shouldn't get or return NaN, but that just isn't feasible.  So with my patch we'll allow for the fact that this can happen (esp. during initialization) and I changed the functions that used the return value from getXCoordFromValue to be able to work ok if it did return NaN. 
Comment 3 aaronr 2007-04-18 15:02:13 PDT
Created attachment 262040 [details] [diff] [review]
patch
Comment 4 alexander :surkov 2007-04-18 18:48:50 PDT
Comment on attachment 262040 [details] [diff] [review]
patch

fine
Comment 5 Merle Sterling 2007-04-19 09:45:06 PDT
Looks good and works for all of the testcases I've tried. r=me
Comment 6 alexander :surkov 2007-04-19 10:41:12 PDT
(In reply to comment #5)
> Looks good and works for all of the testcases I've tried. r=me
> 

Merle, it would be great if you'll set r+ additionally :)
Comment 7 Merle Sterling 2007-04-19 11:07:14 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > Looks good and works for all of the testcases I've tried. r=me
> > 
> Merle, it would be great if you'll set r+ additionally :)

It would be great if I were authorized to edit the bug so I could set the r+. :)
Comment 8 alexander :surkov 2007-04-19 11:10:48 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > Looks good and works for all of the testcases I've tried. r=me
> > > 
> > Merle, it would be great if you'll set r+ additionally :)
> 
> It would be great if I were authorized to edit the bug so I could set the r+.
> :)
> 

Oops :) Allan got rights for me and I don't know the procedure. I guess you should ask Aaron.
Comment 9 aaronr 2007-04-19 15:17:05 PDT
Comment on attachment 262040 [details] [diff] [review]
patch

r+'ing for merle since he commented patch was ok
Comment 10 aaronr 2007-04-19 18:56:40 PDT
checked into trunk
Comment 11 aaronr 2007-04-24 19:15:20 PDT
checked into 1.8 and 1.8.0 branches

Note You need to log in before you can comment on or make changes to this bug.