Can't log in as developer to addons any more

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Administration
--
major
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Neil Bird, Assigned: fligtar)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

I've been trying for a few weeks now to log back into the addons site, but it won't accept me via the new set up (the old login page seems to have moved).

My login/email is: mozilla@fnxweb.com

If I try to log in with my previous details, I get a message asking me to confirm my account by clicking through the email I've 'been sent';  this may have been sent years back when I signed up, but not recently.  If I then click on the 'resend this' link provided, I get a page saying that it has been resent, but I don't actually receive anything [not going into junk, and the email address does otherwise work].

A similar thing happens if I follow the 'forgotten password' link;  it says an email has been sent, but nothing arrives.

I am considering trying to recreate the account, but I don't want to lose access to my extensions.

I need to update both of my extensions (one of which no-oe can download now, I think because AMO has put a '+' in the filename and now doesn't like that);  could someone please investigate my account status and/or let me know how to proceed?


Reproducible: Always

Steps to Reproduce:
(see 'Details')
Tjebbe (author of Mailbox Alert) has the sam problem.

Confirming and setting priority to major.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.0

Comment 2

11 years ago
One thing i noticed is that it doesn't actually matter whether you use a correct password or not, even with a bad password you get the page telling you to click on the link in the email.
(Assignee)

Comment 3

11 years ago
I just registered a test account and received the e-mail. I also tried resending the code and it was resent.

Can one of you go to http://preview.addons.mozilla.org and try resending/registering there and seeing if the e-mail comes? And if that doesn't work, can you see if a different e-mail provider will work there?

Comment 4

11 years ago
indeed, a completely different account does work.

Turns out the address that the confirmation mail was sent from has been blacklisted by some spamlists (yes i know we shouldn't use those, apparently my e-mail provider ignored my request for that, i'm gonna ask again):

http://cbl.abuseat.org/lookup.cgi?ip=63.245.208.146

Name: webapp01.sj.mozilla.com
Address: 63.245.208.146
(Assignee)

Comment 5

11 years ago
I e-mailed our director of IT to see about us getting removed from that blacklist.

I also confirmed the reporter's account and Tjebbe's.

Resolving as a user administration request.
Assignee: nobody → fligtar
Component: Developer Pages → Administration
QA Contact: developers → administration
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.