The default bug view has changed. See this FAQ.

message level="ephemeral" not working on branch

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
10 years ago
8 months ago

People

(Reporter: Steve Speicher, Assigned: aaronr)

Tracking

({fixed1.8.0.12, fixed1.8.1.4})

1.8 Branch
fixed1.8.0.12, fixed1.8.1.4

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 2 obsolete attachments)

2.47 KB, application/xhtml+xml
Details
5.09 KB, patch
smaug
: review+
Doron Rosenberg (IBM)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

This works on 4-17 trunk but can't get the 4-17 1.8 branch version to work.

This is normative W3C test case 10.1.12.c

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 261944 [details]
test case
(Assignee)

Comment 2

10 years ago
a bit of this was that the patch for bug 349643 wasn't marked to get moved to the branch so the QI to nsIXFormsEphemeralMessageUI failed in nsXFormsMessageElement::ShowEphemeral().  But even after I apply the patch and fixed it up to fit on the branch, the QI is still failing.  Looking at the XBL bindings in the DOMInspector it looks like the right hierarchy is applied so the QI should work.  But the anonymous content isn't in DOMInspector so something is going wrong somewhere.  ugh, I hope this isn't another xbl bug that got fixed in the trunk but not on the branch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 1.8 Branch
(Assignee)

Updated

10 years ago
Blocks: 353738
(Assignee)

Comment 3

10 years ago
Created attachment 262964 [details] [diff] [review]
patch

The problem turned out to be that since xf:action contains xf:message and xf:action ISN'T inherited from nsIXTFBindableElement, then that would prevent any XBL that is supposed to bind to the xf:message from actually attaching.  But if that same xf:message were outside of an xf:action, it would work fine.  This patch fixes the problem by making nsXFormsActionElement inherit from nsXFormsBindableControlStub.  I don't know if that is the right answer, though.  Perhaps we should move the Get/Set/UpdateRepeatState from nsXFormsBindableControlStub into nsXFormsBindableStubElement and have nsXFormsActionElement inherit from that.
(Assignee)

Comment 4

10 years ago
Comment on attachment 262964 [details] [diff] [review]
patch

bah, problem with the patch.  Had part of another patch in it.
Attachment #262964 - Attachment is obsolete: true
(Assignee)

Comment 5

10 years ago
Created attachment 262967 [details] [diff] [review]
patch

this one will work
(Assignee)

Comment 6

10 years ago
Doesn't make sense to move Get/Set/UpdateRepeatState to nsXFormsBindableStub since they need mHasParent and mHasDoc, which are also needed by nsXFormsControlStubBase which doesn't inherit from nsXFormsBindableStub.  So I'll make nsXFormsActionElement inherit from nsXFormsBindableControlStub and override the parts of nsXFormsControlStubBase, etc. that don't make sense for nsXFormsActionElement.  For example, GetUsesSingleNodBinding is certainly not PR_TRUE for action element.
(Assignee)

Updated

10 years ago
Assignee: xforms → aaronr
(Assignee)

Comment 7

10 years ago
Created attachment 263055 [details] [diff] [review]
patch2

action has no binding attrs so most of the functions inherited via nsXFormsControlStubBase won't apply to it so I think we are safe not stubbing them all out.  Action should manage its own mHasParent and mHasDoc because calling into parent class' ::ParentChanged and ::DocumentChanged adds overhead that it doesn't need.  Dropped mElement from nsXFormsActionElement since it will pick it up from nsXFormsControlStubBase, now.
Attachment #262967 - Attachment is obsolete: true
Attachment #263055 - Flags: review?(Olli.Pettay)
(Assignee)

Updated

10 years ago
Attachment #263055 - Flags: review?(doronr)

Updated

10 years ago
Attachment #263055 - Flags: review?(doronr) → review+

Updated

10 years ago
Attachment #263055 - Flags: review?(Olli.Pettay) → review+
(Assignee)

Comment 8

10 years ago
checked into 1.8 and 1.8.0 branches
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.8.0.12, fixed1.8.1.4
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.