edit menu commands not updated properly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
11 months ago

People

(Reporter: enndeakin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bacon)

(Reporter)

Description

12 years ago
The enabled state of the Undo/Redo/Paste edit menu commands are not being updated after an operation that should cause this.

In the sidebar, I can't figure out how the clipboard commands are updated, but undo isn't being updated at all. In the places window, the commands are not updated until the focus or selection is changed.
(In reply to comment #0)
> The enabled state of the Undo/Redo/Paste edit menu commands are not being
> updated after an operation that should cause this.
> 
> In the sidebar, I can't figure out how the clipboard commands are updated, but
> undo isn't being updated at all.

i deleted a bookmark from the sidebar, and confirmed that the undo menu reflected this. then i undid it, and confirmed that redo was enabled and performed as expected.

> In the places window, the commands are not
> updated until the focus or selection is changed.
> 

delete/move/etc all work, but changes to properties of individual items (eg: change the title of a bookmark via the properties pane) are not in the undo stack. maybe this is intentional though? mano?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
(Reporter)

Comment 3

6 years ago
I think the original bug was about moving and deleting items. For example, open the bookmarks dialog and select a bookmark, open the Edit menu and the Undo item is enabled, despite that I haven't done anything to undo yet.

But as described in comment 1, editing the properties in the bookmarks window also doesn't update the edit menu properly, although the keyboard shortcuts and context menu are working.
Whiteboard: bacon
AFAICT all issues in this bug are fixed or WFM. Editing properties is hooked up to the undo/redo menus. Also starting up then opening the bookmarks window, the edit menu seems to be working fine.

Hence marking as WFM. Please reopen/file new bugs if you see specific issues.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.