Many Tb dictionaries are not compatible with final Tb2 release

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Dictionaries
VERIFIED FIXED
11 years ago
2 years ago

People

(Reporter: cilias, Assigned: fligtar)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
Just came across this in mozilla.support.thunderbird.
Now that Thunderbird 2 is released, a user who upgraded, wanted to download dictionaries lost in bug 216382, and is finding that some popular dictionaries are not compatible with Thunderbird 2.0.0.0. (MaxVersion set to 2.0b1, or some other beta/alpha)

Confirmed incompatible dictionaries so far:
en-gb, de-de
We've gone through and fixed dynamic data, but those dictionaries who have install.rdf values that are confusing the clients will have to be updated (files reuploaded).

Can you help us come up with a list so we can track this?  Also, Justin Scott has already emailed the dictionary authors about the problem.  Hopefully we can get this resolved quickly.
(Assignee)

Comment 3

11 years ago
Why does bugzilla hate me? If I had said bug 367417 comment 14 it wouldn't work properly either :(
(Reporter)

Comment 4

11 years ago
(In reply to comment #1)
> Can you help us come up with a list so we can track this?  

I'm testing each one right now.

Justin, you're hilarious. :)
(Reporter)

Comment 5

11 years ago
Incompatible:
Catalan	Català (ca)
cy-gb	cy-gb
de-at	de-at
eo-eo	eo-eo
Basque	Euskara (eu)
Finnish	Suomi (fi)
Hungarian	Magyar (hu)
Icelandic	Íslenska (is)
Lithuanian	Lietuviu; (lt)
nl-nl	nl-nl
Polish	Polski (pl)
Romanian	Română (ro)
Russian	Русский (ru)


I get an invalid install package error with:
Croatian	Hrvatski (hr)
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> Incompatible:

and that's not including en-gb and de-de, which were mentioned in comment 0.
(Assignee)

Comment 7

11 years ago
Chris,

I just downloaded and installed 2 dictionaries from that list (Basque and Polish) in 2.0.0.0 and they checked compatibility and worked fine.

Could you check again? Maybe you were still catching the cache from before they were updated.
(Reporter)

Comment 8

11 years ago
Cool. Out of that list Romanian is the only one that isn't compatible now.
(Croatian still isn't a valid install package.)
(Assignee)

Updated

11 years ago
Assignee: nobody → fligtar
Version: unspecified → 3.0
(Assignee)

Comment 9

11 years ago
The Croatian dictionary's download url is https://addons.mozilla.org/en-US/firefox/downloads/file/13906/croatian_dictionary_-_hrvatski_rje%C4%8Dnik-1.0.1-firefox+thunderbird+seamonkey.xpi which doesn't like the html entities in the filename. If you remove that part (the  filename actually isn't necessary, it's just for display) it works. So, I'm going to file another bug about that issue.

I downloaded and was able to install the Romanian dictionary without issue in TB 2.0.
(Assignee)

Updated

11 years ago
Depends on: 377994
(Reporter)

Comment 10

11 years ago
Yup. Romanian works now.

Comment 11

11 years ago
(In reply to comment #7)
> I just downloaded and installed 2 dictionaries from that list (Basque and
> Polish) in 2.0.0.0 and they checked compatibility and worked fine.

Although in Basque install.rdf file minVersion is set to 2.0a1 and maxVersion to 2.0b1, it works :/
In AMO control panel min and max versions are set properly (2.0 - 3.0a1), but the xpi file isn't updated.

So here's something I don't understand.
As with all other add-ons, the app will check the update URL for compatibility information when installing, in case the compatibility has been extended (or retracted) since the XPI was built.  This happens as long as the app can contact the update server, so it's only really a problem for people who try to install the add-on, such as a dictionary, when not connected to the internet.

I think this is FIXED.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.