"Recently closed tabs" grayed out with sessionstore set to true

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Thomas Hettenhausen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

The feature to re-open a closed tab either by right-clicking the tab bar or using the history menu entry "Recently closed tabs" is not working. The history menu entry is grayed out.
browser.sessionstore.enabled is set to true.
browser.sessionstore.max_tabs_undo is set to 10.
This happens without any tabbed browsing behavior changing extension installed.

Only extensions installed:
AdBlock
AdBlock FilterSet.G Updater
Firebug
Gmail Manager
Google Bookmarks Button
Locale Switcher
ODFReader
ScreenGrab
Stylish
SwitchProxy Tool
ViewCookies


Reproducible: Always

Steps to Reproduce:
I am sorry, but this does not happen just so when I do something specific, but whenever I now use Firefox.
Works for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Did you try:
- safe-mode
- a new profile
- reinstallation in a new empty folder?
http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder

Comment 2

11 years ago
This should be WORKSFORME. Still, to further investigate the issue, please install the Console² extension from https://addons.mozilla.org/firefox/1815 and open the Error Console (Tools menu) and display all Chrome JS Errors by middle-clicking the relevant buttons. Then close a non-blank tab, verify that the Recently closed tabs submenu is grayed out and copy&paste all errors from the console here (unless they obviously belong to one of the installed extensions).
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
(Reporter)

Comment 3

11 years ago
Okay, took me some time because on the day I reported addons.mozilla.org was down... anyway, I just tried, and upon closing a new blank tab nothing new appears in the error log. When I open a new tab and load a page in it, though, I get this error:

Fehler: Cc['@mozilla.org/browser/sessionstore;1'] has no properties
Quelldatei: chrome://browser/content/browser.js
Zeile: 6347

To me this seems related.

Comment 4

11 years ago
Apparently the SessionStore component (which is needed for the recently closed tabs) hasn't been correctly registered on your profile - or even might be missing.

Please locate your profile folder (cf. http://kb.mozillazine.org/Profile_Folder ), delete the file compreg.dat and restart Firefox. If that doesn't help, you might have to uninstall and then cleanly reinstall Firefox (you won't lose any data during the reinstallation). Does any of those two things help?
Thomas, can you respond to comment 4?
Whiteboard: CLOSEME - 06/13
(Reporter)

Comment 6

11 years ago
Sorry, this only happens on my work notebook, where I do not always have full access to the internet.

Tested it now: first I only removed the comreg.dat file from my profile, no change, then I uninstalled Firefox and reinstalled Firefox from a freshly downloaded installer, no change either.

After that I created a new profile, and now the feature works again. So it must be something inside the profile that can corrupt this functionality. Is tehre a way to figure this out except by simply using this new profile and each time copying somthing over from the old one?
Thomas, thanks for reporting back. I'm going to close this bug as WORKSFORME.

If you'd like, you can run through file-by-file (or a few files at a time) and try and determine what the problem was which caused this issue for you. Presumably it was an extension that left remnants in your profile. If you can determine that it wasn't caused by an extension, feel free to file a new bug detailing the problem and how it occurred.

http://kb.mozillazine.org/Migrating_settings_to_a_new_profile
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Whiteboard: CLOSEME - 06/13
You need to log in before you can comment on or make changes to this bug.