If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cmd-click-release (Mac) to load link in new window

VERIFIED DUPLICATE of bug 12056

Status

SeaMonkey
General
P2
enhancement
VERIFIED DUPLICATE of bug 12056
18 years ago
13 years ago

People

(Reporter: Stanton McCandlish, Assigned: Bill Law)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][5/16][dogfood-])

(Reporter)

Description

18 years ago
Related to bugs 18726, 31775, 30089 (in part), 37804.



IE, and (I think) Netscape Navigator/Communicator have long supported 
Cmd-Click-then-release on an <A HREF...></A> to load the linked item into a new 
window.  This is a very Good Thing.  Please replicate this functionality in 
Mozilla. (If Netscape doesn't do this, too, it should in my opinio
nothing to do with xpmenus.

i totally agree though. i use this daily in 4.x. it's dogfood for me.
Assignee: pinkerton → don
Component: XP Toolkit/Widgets: Menus → XPApps
Keywords: dogfood
(Reporter)

Updated

18 years ago
Component: XPApps → XP Toolkit/Widgets: Menus
(Reporter)

Comment 2

18 years ago
Retitling (had the wrong summary; oops!), moving to general category, and 
adding:

I should add that this is probably Ctrl-click-release or maybe right-click 
release in Windows, I'm not sure.  I was just basically suggesting whatever 
IE-like functionality one expects on whatever platform one is using. It's 
Cmd-click-release in M
Summary: Cmd-click should bring up context menu on Macs → Cmd-click-release (Mac) to load link in new window
(Reporter)

Updated

18 years ago
Component: XP Toolkit/Widgets: Menus → Browser-General

Comment 3

18 years ago
Putting on [nsbeta2+][dogfood-] radar.  Need fix for beta by May 16.
Whiteboard: [nsbeta2+][5/16][dogfood-]

Comment 4

18 years ago
Setting from Unconfirmed to New since pinkerton also agrees.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Bill, I know whe have another bug like this somewhere, don't we?
Assignee: don → law
Priority: P3 → P2
Target Milestone: --- → M17
(Assignee)

Comment 6

18 years ago
Yes, we do have another but like this (note: at some point we will have so many 
bugs that every conceivable new bug will be a dup :-).  That bug is #12056.  I'm 
resolving this one as a dup.  That bug has some description of the possible 
solution but it a bit dated (talks about nsWebShell stuff).  The problem will 
have to be re-assessed.

*** This bug has been marked as a duplicate of 12056 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
vrfy
Status: RESOLVED → VERIFIED
Adding keyword to bugs which already show a nsbeta2 triage value in the status 
whiteboard so the queries don't get screwed up.
Keywords: nsbeta2
Product: Browser → Seamonkey

Updated

13 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.