Toggle view and edit html source code

RESOLVED DUPLICATE of bug 143593

Status

--
enhancement
RESOLVED DUPLICATE of bug 143593
12 years ago
11 years ago

People

(Reporter: u142003, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0 (20070326)

In Outlook Express there is an option to show three tabs at the bottom of the compose mail window, namely: Edit, Source, Review. While the Review tab IMHO is quite unnecessary, the Source tab is really useful in certain cases. A similar feature is something that I think should be implemented in a future version of Thunderbird. 

I know there is a way to edit the source html by clicking "Insert" > "HTML...," but there two reasons for adopting the OE approach:
1. The term "Insert" doesn't really cover the scope of feature since besides inserting html (or text) you can also edit the source.
2. The modal window is initially too small (in most cases) and quite featureless. Syntax highlighting (as in Firefox) would be useful here.

Reproducible: Always

Comment 1

12 years ago
The lack of ability to edit the source code of emails is one of the only 2 things making Thunderbird unsuitable for my needs. I'm a web developer, so I know how to write good markup and CSS already, I just need the ability to edit the source directly in the application.

A related issue (not sure if it should be a seperate bug/requset) is the ability to switch modes between "plain text" and "rich text (HTML)".

By that I mean:

1. When starting a new message, the ability to choose what format it should be. Eg; "create new rich text (HTML) message" and "create new plain text message".

2. The ability to change formats once you've started composing the message.
For example once a plain text message has been started, realising the need (or desire) to include an HTML style link (eg, link text rather than just including the URL in the message as with plain text) currently the only way is to copy all the text, close the message and open a new one using HTML formatting, paste the text and add links where needed/desired.

Conversion from plain text to HTML should be simple enough, and HTML to plain text shouldn't be that much more difficult;
things like moving the URL of links into brackets after the text which was the link anchor:

from:
<a href="http://web.site.tld/path/">link text</a>

to:
link text (http://web.site.tld/path/)

Comment 2

12 years ago
Additional thoughts to comment 1:

Edit Source should obviously give you the source of the entire message, not just the <body> (so competent users can enter CSS in <style> which is in the <head>.
Also to change the Doctype if the so desire.

As for the plain-text/HTML format switching - there should be an option in the prefs for which to use as the default.
My personal preference is to use plain text unless I have a reason to use HTML (eg more visually appealing links)

Comment 3

11 years ago
Edit HTML Source extension became indispensable when creating html emails. Unfortunately, this extension became incompatible with the advent of Thunderbird 2.0. The developer has not updated it since 2005; and has not frequented the Mozille forums for sometime.

I realize one could use Insert > HTML and edit the source in another application. I found this approach cumbersome since Thunderbird dealt better with copying & pasting html text from a web page or Word. With the Insert > HTML approach, I would have to copy&paste into Thunderbird; open the source with an editor (extension); makes edits; then verify changes by Insert > HTML. If your html source had errors, then it meant several round trips between the editor and Thunderbird. The Edit Source extension allowed one to quickly edit the source and view the result; you could even copy & paste the source text into another editor for running html tidy or script (easier than saving the message as html).

I really found this extension essential for editing emails with html tables and creating daily status reports from spreadsheets (OpenOffice Calc). It helped me clean the code when copying & pasting from Word. Sometimes, cleaner html would allow one to display html formatting on a small mobile screen. Hopefully, some developer would be willing to integrate this feature into Thunderbird. Plain text does not suffice for showing column and row type data.

Comment 4

11 years ago
(In reply to comment #1)
> 1. When starting a new message, the ability to choose what format it should be.
> Eg; "create new rich text (HTML) message" and "create new plain text message".

See Suite bug 16908.
 
> 2. The ability to change formats once you've started composing the message.

Duplicate of bug 216132 and Core bug 140800.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 143593
You need to log in before you can comment on or make changes to this bug.