Mozilla 5 has max size limit on JavaScript file

VERIFIED DUPLICATE of bug 21637

Status

()

Core
JavaScript Engine
P3
blocker
VERIFIED DUPLICATE of bug 21637
18 years ago
16 years ago

People

(Reporter: Tony Fu, Assigned: Phil Schwartau)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
There seems to be a limit on the size of JavaScript file.  My preliminary 
investigation ndicates that it may be 64k.  Beyond that the page will stop 
loading without any warning.  Personally, I don't think there should be a 
limit.  If it is neeeded for easier coding, I guess 256k seems to be more 
reasonalbe size.

Comment 1

18 years ago
--> phil, would you try building a suitablly fat test case and trying it on 
shell & browser (i'm guessing it's an html parser issue not the engine)
Assignee: rogerl → pschwartau
Confirming to get this on developer's radar.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

18 years ago
Sorry for the delay - I have just taken over as QA for the JS Engine.

I do not observe any problem with loading JS files just because they are 
large. I do not encounter any limit of 65K. You can make very large JS files 
that load just fine either in the Mozilla browser or the JS Shell.
If it is an HTML parsing problem, it would seem to be a duplicate of bugs 21637, 
37409, 36285. Am marking this one as a duplicate -

*** This bug has been marked as a duplicate of 21637 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.