Keyboard shortcuts inconsistent in bookmark toolbar

RESOLVED DUPLICATE of bug 301888

Status

()

--
minor
RESOLVED DUPLICATE of bug 301888
12 years ago
12 years ago

People

(Reporter: tyson.brandes, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

right-clicking on a bookmark in the bookmark toolbar and pressing 't' will cut the bookmark. This is inconsistent with behavior throughout the rest of firefox, where right-click and then 't' usually brings up the item in a tab. On the current context menu, 'w' brings up the item in a tab. 't' is currently used by the "cut" command, which has little use in the context of the toolbar folder; if the user wanted to juggle toolbar buttons, they would just click-and-drag. Recommend changing the keyboard shortcut for cut to 'u'.

Reproducible: Always

Steps to Reproduce:
1. Right-click on any bookmark in toolbar
2. Press 't' on keyboard
Actual Results:  
clicked-on bookmark is cut.

Expected Results:  
open the bookmark in a new tab.

Recommend juggling of the keyboard shortcuts as such:
Cut -> 'u'
Open in tab -> 't'
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301888
You need to log in before you can comment on or make changes to this bug.