Buttons in "Advance to next folder" query have the wrong SPC default

RESOLVED DUPLICATE of bug 378108

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 378108
11 years ago
11 years ago

People

(Reporter: Andreas Fuchs, Assigned: Scott MacGregor)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US) AppleWebKit/420+ (KHTML, like Gecko, Safari/420) OmniWeb/v607.17
Build Identifier: version 2.0.0.0 (20070326)

When asking whether to advance to the first unread message in the next mailbox, Thunderbird 1.5 used to open an Ok/Cancel type message box, with OK as the default for activation with the Return key (and on the Mac, for the space bar as well). 

In 2.0, it opens a Yes/No type query, and the default for hitting Space on the Mac is now "No", which to me is a big source of "WTF" moments, as up until 2.0, I used to hit space twice to advance to the next mailbox/newsgroup. AFAICT, this behavior would be consistent with the other platforms (Windows and Linux), as well.

Reproducible: Always

Steps to Reproduce:
In Mac OS X and Thunderbird 2,

1. Go to a folder with no unread messages
2. Have another folder with unread messages
3. Hit N
4. Observe the defaults on the buttons in the dialog box that pops up.
Actual Results:  
Yes will be activated when hitting Return only (it's shiny blue, but has no additional blue border)
No will be activated when hitting Space (has the blue border)

Expected Results:  
Yes should be activated when hitting Return or Space.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378108
You need to log in before you can comment on or make changes to this bug.