bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Horizontal scrolling broken with IBM Trackpoint

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Boris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Horizontal scrolling with IBM Trackpoint works in Internet Explorer but not Firefox.

Reproducible: Always

Steps to Reproduce:
1. Hold middle button
2. Press trackpoint horizontally
3. For pages with horizontal scrollbar like large pictures, it does not scroll horizontally.
Actual Results:  
Nothing

Expected Results:  
Scroll horizontally smoothly like scrolling vertically.

Comment 1

10 years ago
Tested with latest nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042506 Minefield/3.0pre). The problem is still there!

Comment 2

10 years ago
Just a quick note. Scrolling sideways works in IE7 but not in Opera 9.5 beta 2.
Did you upgrade your driver to the latest one ?
This is a driver issue and not a Firefox Bug, your driver fails to send us scroll events.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.