wrong background-position in embedded element

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: konference, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070416 BonEcho/2.0.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070416 BonEcho/2.0.0.3

.MainBoard{
    position: static;
    background-image: url(data/background5.png);
    background-position: 100px 100px;
    background-repeat: no-repeat;
    background-attachment: fixed;
    background-color: #3d4983;
    color: white;
    padding: 5px;
    width:100%;

}

Position of image data/background5.png is calculate from window object, not from element.


Reproducible: Always




web pages will be available from 23.04.2007
I think this bug needs more context. Please can you make a minimal testcase and attach it to this bug with the 'Add an attachment' link? Thanks!
Actually we don't need any more for this. This is not a bug, by positioning the image relative to the window Firefox is behaving according to the CSS spec:

"If the background image is fixed within the viewport (see the 'background-attachment' property), the image is placed relative to the viewport instead of the element's padding area."

http://www.w3.org/TR/CSS21/colors.html#propdef-background-position
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.