Closed Bug 378369 Opened 13 years ago Closed 13 years ago

Crash [@ nsEventListenerManager::FixContextMenuEvent] when firing contextmenu event in display: none iframe

Categories

(Core :: DOM: UI Events & Focus Handling, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: smaug)

References

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(2 files)

Attached file testcase
See testcase, which crashes current trunk builds after 300ms, it doesn't crash on branch.
I could look for a regression range, if wanted.

Talkback ID: TB31426666Z
nsEventListenerManager::FixContextMenuEvent  [mozilla/content/events/src/nseventlistenermanager.cpp, line 1408]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nseventlistenermanager.cpp, line 1140]
nsEventTargetChainItem::HandleEvent  [mozilla/content/events/src/nseventdispatcher.cpp, line 209]
nsEventTargetChainItem::HandleEventTargetChain  [mozilla/content/events/src/nseventdispatcher.cpp, line 241]
nsEventDispatcher::Dispatch  [mozilla/content/events/src/nseventdispatcher.cpp, line 484]
nsEventDispatcher::DispatchDOMEvent  [mozilla/content/events/src/nseventdispatcher.cpp, line 538]
nsDocument::DispatchEvent  [mozilla/content/base/src/nsdocument.cpp, line 4666]
NS_InvokeByIndex  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2247]
No Crash
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060307 Firefox/1.6a1 ID:2006030704 [cairo]

Crash
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060308 Firefox/1.6a1 ID:2006030807 [cairo]

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-03-07+03&maxdate=2006-03-08+08&cvsroot=%2Fcvsroot
(In reply to comment #2)
> Due to bug 234455?

Yeah, probably.
Blocks: 234455
Assignee: events → Olli.Pettay
Attached patch null checkSplinter Review
Attachment #262472 - Flags: superreview?(jst)
Attachment #262472 - Flags: review?(jst)
Comment on attachment 262472 [details] [diff] [review]
null check

r+sr=jst
Attachment #262472 - Flags: superreview?(jst)
Attachment #262472 - Flags: superreview+
Attachment #262472 - Flags: review?(jst)
Attachment #262472 - Flags: review+
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Verified fixed, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070427 Minefield/3.0a4pre
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsEventListenerManager::FixContextMenuEvent]
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.