Inline spell checking: Language setting of subject line and body not synchronized, but temporarily appears so when changing language and depending on focus (confusing ux)

RESOLVED DUPLICATE of bug 717292

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 717292
11 years ago
3 years ago

People

(Reporter: Tobias Bußmann, Unassigned)

Tracking

({ux-mode-error, ux-userfeedback})

ux-mode-error, ux-userfeedback

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [STR comment 24])

Attachments

(5 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4 (MultiLang)
Build Identifier: Version 2.0.0.0 (20070326)

Since Bug 3459 we have this great support of spell checking the subject line. Unfortunately if you change the language setting in the body text, the subject line is still checked according to the old language setting.

Reproducible: Always

Steps to Reproduce:
with the German and English dictionary installed, enter "Dies ist eine deutsche Nachricht. This is an English test message." in both the mail body and the subject  line. Then switch between the dictionarys. 
Actual Results:  
You see the red underlines changeing according to the choosen language in the body but not in the subject line.

Expected Results:  
The subject line should always use the same language setting as the message body.
(Reporter)

Updated

11 years ago
Depends on: 3459
i can confirm this bug with the steps to reproduce from comment#1, the spell check on the subject line don`t change.

confirmed on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 2.0

Comment 2

11 years ago
I think this can be fixed here: http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/mail/components/compose/content/MsgComposeCommands.js&rev=1.112&mark=2288,2289#2272 by just putting something like:

document.getElementById('msgSubject').spellCheckerUI.mInlineSpellChecker.spellCheckRange(null);

in the |if|. I can make a patch and test this once I get a build environment for Thunderbird set up, but that may be a while. Feel free to take yourself if I don't get to it first.
Status: NEW → ASSIGNED

Comment 3

11 years ago
Meant to assign this to myself.
Assignee: mscott → ispiked
Status: ASSIGNED → NEW

Comment 4

11 years ago
I add another, possibly related behaviour (tell me if I should report it separately): 

In "Options", "Spelling", 
having unchecked "check spelling before sending"
having unchecked "enable spell check as you type"

I reply to existing emails (ie not writing to the subject line myself) and the composition window is opened with words underlined in red by the spell checker. If I change the subject, "spell check as you type" is active, even though not enabled  from prefs. 
(In reply to comment #2)
> I think this can be fixed here:
> http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/mail/components/compose/content/MsgComposeCommands.js&rev=1.112&mark=2288,2289#2272
> by just putting something like:
> 
> document.getElementById('msgSubject').spellCheckerUI.mInlineSpellChecker.spellCheckRange(null);
document.getElementById('msgSubject').inputField.parentNode.spellCheckerUI.mInlineSpellChecker.spellCheckRange(null);

That line works, but the problem is, that it's a one way solution. Changing the language in the context menu of the subject inputField only checks the subject line, but the message body isn't checked with the new dictionary.

Updated

10 years ago
Assignee: ispiked → nobody
I'd like the spelling checker icon to be enabled whether you're on the subject line or in the mail body and let spelling checker use same language for both (as you type, before sending or from the menu/button).

In reply to comment #4
> If I change the subject, "spell check as you type" is active, even though not
> enabled  from prefs.
That is bug 369104
(In reply to comment #6)
> I'd like the spelling checker icon to be enabled whether you're on the subject
> line or in the mail body and let spelling checker use same language for both
Seems also to be another bug 368915 for enabling button on subject.

Updated

9 years ago
Depends on: 368915

Updated

9 years ago
Duplicate of this bug: 529258

Comment 9

7 years ago
This bug is still around in TB v9.0.1. According to another report (Bug 3459) this issue has been around since 1998. It's really annoying for international users. Thanks in advance for your help!

Comment 10

7 years ago
Interestingly spell checking in TB (any version) works fine on Mac OS X for the subject line if you use a build that uses the osx spellchecker instead of hunspell.
http://img12.imageshack.us/img12/1636/bildschirmfotoa.jpg
I am running this on Windows, with Thunderbird 9.0.1.

The spell check works for the subject line AND for the body of the message.

The only problem that remains is that as long as the focus is in the subject line, you can't switch language. See enclosed.
Created attachment 586707 [details]
Screen shot. Spelling works but "spelling" button greyed out.

Comment 13

7 years ago
Created attachment 586770 [details]
French spell checker is on, but this does not seem to work at all...
Attachment #586770 - Flags: feedback+

Comment 14

7 years ago
Thanks Nomis and Jorg for your feedback. I feel that my first report is missing the point, since I can't reproduce now what I observed yesterday... However, there are strange things going on in the spell check area, since language preferences seem to be quite unstable. See Attachment 586770 [details] for an example. I don't know how to move from here: is there some spell check "test suite" I could "run" to provide you with more useful information? Thanks in advance for your help!
Created attachment 586774 [details]
Screen shot that show that French spelling works!

I don't know what you are doing. French spelling works for me like a charm. I'm using "Dictionnaires français 4.4.1
https://addons.mozilla.org/en-US/firefox/addon/dictionnaires-fran%C3%A7ais/
It also worked with the previous version 4.3 of this add-on.
Created attachment 586775 [details]
Screen shot that show that French spelling works! - take 2

Sorry, you didn't see the subject line in the previous screen shot, now you do.
Now I'd like to return to the problem I have.

The spelling button is disabled unless you save the message.

Steps to reproduce:
1) Start TB (only seems to happen on the first reply you do in a session)
2) Hit reply on a message you previously received.
3) place the cursor into the message body.
   "Spelling" button disabled.
4) Save the message as a draft (ctrl S)
5) "Spelling" button enabled.
That's a bug!
See enclosed.
Created attachment 586780 [details]
Screen shot thas shows that the "Spelling" button is disabled when I reply.

Comment 19

7 years ago
Thanks Jorg for this new info. By the way, I don't know which French spell checker I am using since it was preinstalled with the France-localised version of TB I use.

My current problem with the spell check is not related to French spell check, in fact. Let me give you an example: I select French or English UK spell check and write my email in French or UK English without problem; then when I click on "Send email" and suddenly my entire email is full of spelling mistakes because the selected dictionary is... Italian!

And now comes the paranormal phenomenon... :-) A while ago, I deactivated my Italian spell checker in my France-localised Firefox. The spell check was fine under Firefox, but spell checking oscillations started to show up in TB. As an experiment, I deactivated 10 minutes ago the Italian spell check also in TB, and after clicking on "Send email", the (ghost) bug I described before seemed to have vanished! Quite a story, isn't it? :-)

Concerning your new bug report, I do confirm that I also have observed the "disabled spelling button" bug, but, in my case, I observe it when I put the focus (ie. click with the mouse pointer) in the Subject field...
I'm not sure what do do from here. I use a few dictionaries (German, English US, English AU, Spanish, French x 4) and spelling works in the subject and the body. The only problem is that at times, the "Spelling" button is greyed out. But as described above, it can be solved by saving the message as a draft. The button is sometimes greyed out when the subject line has the focus, but at times, as described, it can also be disabled while the focus is in the body.

Please advise if I should try something else for you.

I certainly never saw a problem after clicking on "Send".

Comment 21

7 years ago
Well Jorg, let's consider these as "non blocking bugs that do no show up too often" and thus could be considered as a waste of time to fix... However, I'm quite curious to know about the potential influence of Firefox add-ons on Thunderbird add-ons... Is there something shared between the two clients? I really can't explain what happened on my side. Thanks for your help!
I'd like to differ here. Disabling part of the user interface for no apparent reason is quite puzzling and very annoying to the user. And saving the message to get access to the language selection is not an obvious work-around.

And the bug is reproducible, so it's not an intermittent bug that one would need days to chase.

I would like to see the bug fixed.

I've been with Thunderbird since version 3 and back then, the spell check in the subject line didn't work at all. Now it's working, so someone has been working on it and I think this someone could easily fix the problem I reported.

Comment 23

7 years ago
Alright Jorg, agreed. I would be glad too to see these bugs fixed!
On a related note (just dumping information), this is wrong and confusing:
1) add English words and some words from another language e.g. German to both subject and body
2) from context menu of either body or subject line, change language
3) with "spell check as you type" enabled, observe spell check error underlining in both body and subject
4) place cursor alternately in subject and body, observe spell checking markings
5) verify language setting in subject and body

Actual result:
3) immediately after changing language, it *looks* as if the other part (body vs. subject) also changes to the same language, as underlinings flip accordingly; but when you actually click into the other part (body vs. subject)...
4) ...you'll see that the underlinings flip back to the language previously active in that part, and...
5) ...language setting of the other part (body vs. subject) is NOT updated/synchronized in the menus.

Expected result:
decide what we want:
a) subject and body = single spell check area OR
b) subject and body = separate spell check areas

if a) single area: ensure synchronizing all aspects of spell checking immediately (language changes, ignored words).
if b) separate areas: ensure keeping all spell check aspects and behaviour separate (well ignored words could still go for all areas, but language changes must be either strictly separate OR sctrictly synchronized)

Current UX is really confusing.
(In reply to Thomas D. from comment #24)
> Expected result:
> decide what we want:
> a) subject and body = single spell check area OR
> b) subject and body = separate spell check areas

...and as long as we don't support sections with different language settings in the body, having the subject as a separate area doesn't make any sense at all, so the currently preferred variant is
a) single spell check area comprising subject and body
Blocks: 3459
No longer depends on: 3459
Actually, I don't see exactly what comment 0 described, so comment 24 might be the more accurate description of this bug.
Keywords: ux-mode-error, ux-userfeedback
Summary: Spell checking of the subject line should respect language changes → Inline spell checking: Language of subject line and body not synchronized, but temporarily appear so when changing language and depending on focus (confusing ux)
Whiteboard: [STR comment 24]
(In reply to Thomas D. from comment #24)
Observed on TB17, WinXP.
Summary: Inline spell checking: Language of subject line and body not synchronized, but temporarily appear so when changing language and depending on focus (confusing ux) → Inline spell checking: Language setting of subject line and body not synchronized, but temporarily appears so when changing language and depending on focus (confusing ux)
Just to clarify:
"From the context menu" means: from the right-click menu, so you right-click and select "Languages >", correct?

I must admit, I didn't know this feature existed, I've never used it. But I can see that it causes confusion.

My pet hate is the following:
When I start a new message the "Spelling" button (the one next to the "Send" button) is disabled. I have to click into the message body first, before I can select the language. Then I can start typing the subject and the body.

Normal would be:
1) Select language
2) Type subject
3) Type message body.
(In reply to Jorg K from comment #28)
> Just to clarify:
> "From the context menu" means: from the right-click menu, so you right-click
> and select "Languages >", correct?

yes

> I must admit, I didn't know this feature existed, I've never used it. But I
> can see that it causes confusion.

indeed

> My pet hate is the following:
> When I start a new message the "Spelling" button (the one next to the "Send"
> button) is disabled.

That's bug 368915, yes, it's annyoing (but still a minor issue compared to many other bugs)

> I have to click into the message body first, before I
> can select the language. Then I can start typing the subject and the body.
> 
> Normal would be:
> 1) Select language
> 2) Type subject
> 3) Type message body.

+1. That's how I'd expect things to work after bug 368915 is fixed.

Jorg, thank you for your continued interest, and sorry for the frustration of slow fixes. However, the same applies to thousands of other TB bugs out there, more so that TB is now maintained by volunteers.
I'm trying to get some traction on bug 717292, a duplicate of this bug.
Duplication pending, but please wait for response to bug 717292, comment 15 to find out which direction of duping.
See Also: → bug 717292
Looks like there's more information and more problem-solving action in bug 717292, so let's dupe there.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
See Also: bug 717292
Duplicate of bug: 717292
You need to log in before you can comment on or make changes to this bug.