Sharing Session data between multiple windows (in any newly opened windows) with PHP application

RESOLVED DUPLICATE of bug 117222

Status

()

Firefox
Disability Access
--
major
RESOLVED DUPLICATE of bug 117222
11 years ago
2 years ago

People

(Reporter: Syamlal M.S, Unassigned)

Tracking

2.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

    I'm a software engineer, working with PHP based web applications development, while I was working with FireFox 2, I've discovered that the browser shares the SESSION data between multiple windows.  
    
    I found this when I was working with a CMS of Multilanguage supported website.  some reasons, we may needed to use the same SESSION values in the front end (live web site) and the administration portal.  Now, what happening is that when I change the session values in the Administration portal, it also changes the same in the front end (live site).  actually, if is very difficult to work in this situation with the FireFox in this situation. This is not happening with IE
 
    But the same time, it is a fact that "People (specially the programmers) using FireFox than IE or any other browser available".  Myself, I too using FireFox for maximum development purpose.  I'm using the other browser only for checking the browser compatibility of my work.
 
    If you could fix this issue at least in the next release of FireFox, it will be a great pleasure for programmers like us.  I don't know whether you have already received information regarding this issue, if so please ignore this mail.

Reproducible: Always

Steps to Reproduce:
1.Create and print a session value using PHP and run the page in a FireFox 2. Now, DO NOT CLOSE THIS WINDOW.
2.After the session session value has been created, open any new instance of FireFox2 and try the same page in the step1
3.You can find that the Session value created in the First Window is passing to all the opened windows.
4.IMPORTANT: This will not happen if you close the first Window (Created in step1)
Actual Results:  
The session data created in the First window will be passed to second or any other window until the first window remains opened.

Expected Results:  
Session Data should not be shared between multiple instance. Please not that not in tabbed windows, but in different windows.

No, I'm not using any Theme,  This issue has been informed by our client as well.
(Reporter)

Comment 1

11 years ago
If you could fix this issue, please let me know the release details.
Version: unspecified → 2.0 Branch
Isn't this basically bug 117222?

Updated

11 years ago
Group: security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 117222
You need to log in before you can comment on or make changes to this bug.