All users were logged out of Bugzilla on October 13th, 2018

When session saving is off, opening the application from a link opens too many tab/windows

RESOLVED FIXED in Camino1.5

Status

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: froodian, Assigned: murph)

Tracking

({fixed1.8.1.4, regression})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1.4, regression
Bug Flags:
camino1.5 +

Details

Attachments

(1 attachment)

1.71 KB, patch
froodian
: review+
stuart.morgan+bugzilla
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Presumably a regression from bug 364497.  First reported here: http://forums.mozillazine.org/viewtopic.php?t=542632

STR:

1. Make sure session saving is off.
2. Quit the app.
3. Open the app via a link

What happens: A window is created (with the home page or about:blank, as expected for new windows), and then the URL is opened in a new tab/window (based on the external apps pref)
What should happen: We should only load the URL

A case could be made that when the user has set the pref to open the home page in new windows, this is expected behavior.  However, it's certainly undesired when new windows open to about:blank and then we load the desired URL in a new tab/window regardless.
Flags: camino1.5?
(Assignee)

Comment 1

12 years ago
(In reply to comment #0)
> Presumably a regression from bug 364497.

Yep, it must be.  I'll take a look and get this behavior back to the way it was before bug 364497.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 2

12 years ago
Sorry, that closing was accidental.  My palm hit the trackpad right when I was submitting the previous comment and mistakingly performed a click on the FIXED button.
Assignee: nobody → murph
Status: REOPENED → NEW
(Assignee)

Comment 3

12 years ago
Created attachment 262532 [details] [diff] [review]
patch

When I moved the application's initialization routines into |ensureInitializationCompleted| as part of bug 364497, I carried along the opening of an initial window and the default browser check as well.  This prompted the start page to load every time because URLs opening during launch have not yet been processed at this point.

Even without the buggy behavior those two steps are best left for applicationDidFinishLaunching anyway, as they're not crucial or required for initialization.
Attachment #262532 - Flags: review?
Target Milestone: --- → Camino1.5
(Reporter)

Comment 4

12 years ago
Comment on attachment 262532 [details] [diff] [review]
patch

r=me
Attachment #262532 - Flags: superreview?(stuart.morgan)
Attachment #262532 - Flags: review?(froodian)
Attachment #262532 - Flags: review?
Attachment #262532 - Flags: review+

Comment 5

12 years ago
Comment on attachment 262532 [details] [diff] [review]
patch

sr=smorgan
Attachment #262532 - Flags: superreview?(stuart.morgan) → superreview+
(Reporter)

Comment 6

12 years ago
Checked in on trunk and MOZILLA_1_8_BRANCH.
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Flags: camino1.5? → camino1.5+
Keywords: fixed1.8.1.4
Resolution: --- → FIXED
(Reporter)

Updated

12 years ago
Duplicate of this bug: 378917
You need to log in before you can comment on or make changes to this bug.