Access violation in nscomptr.h, line 618 when starting up tbird if system is busy.

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Julien Moorrees, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061130 Minefield/3.0a1
Build Identifier: version 3.0a1 (20070421)

When starting up multiple applications including thunderbird, it takes some while for the application is started up. It appears that when this startingup process is not quick enough, an access violation is fired.

Reproducible: Sometimes

Steps to Reproduce:
1. Start up some applications that makes your system busy
2. Start tbird
3.



Maybe it is some multithreading issue. I have an athlon x2 64 dualcore processor. And I see this in the stacktrace:
nsThreadPool::ShutdownThread  [mozilla/xpcom/threads/nsthreadpool.cpp, line 145]
nsThreadPool::Run  [mozilla/xpcom/threads/nsthreadpool.cpp, line 217]
nsThread::ProcessNextEvent  [mozilla/xpcom/threads/nsthread.cpp, line 483]
NS_ProcessNextEvent_P  [mozilla/xpcom/build/nsthreadutils.cpp, line 227]
nsThread::ThreadFunc  [mozilla/xpcom/threads/nsthread.cpp, line 251]
_PR_NativeRunThread  [mozilla/nsprpub/pr/src/threads/combined/pruthr.c, line 458]
(Reporter)

Comment 1

11 years ago
Extra info:
I have the following Trackback ID's
TB31469843H
TB31450400H
TB31425318Y
TB31419063Y

Comment 2

11 years ago
The stacktrace looks pretty similar to the ones in bug 371095 and bug 345810. The nsCOMPtr seems to be holding a different object in each of the crashes.

Incident ID: 31419063
Stack Signature	nsCOMPtr::nsCOMPtr b7d6aeb3
Product ID	ThunderbirdTrunk
Build ID	2007042103
Trigger Time	2007-04-21 18:44:57.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	xpcom_core.dll + (00008f00)
URL visited	
User Comments	
Since Last Crash	13772 sec
Total Uptime	13772 sec
Trigger Reason	Access violation
Source File, Line No.	d:\builds\tinderbox\tb-trunk\winnt_5.2_depend\mozilla\dist\include\xpcom\nscomptr.h, line 627
Stack Trace 	
nsCOMPtr<nsIWindowsRegKey>::nsCOMPtr<nsIWindowsRegKey>  [mozilla/dist/include/xpcom/nscomptr.h, line 627]
NS_GetProxyForObject  [mozilla/xpcom/proxy/src/nsproxyobjectmanager.cpp, line 284]
nsThreadPool::ShutdownThread  [mozilla/xpcom/threads/nsthreadpool.cpp, line 145]
nsThreadPool::Run  [mozilla/xpcom/threads/nsthreadpool.cpp, line 217]
nsThread::ProcessNextEvent  [mozilla/xpcom/threads/nsthread.cpp, line 483]
NS_ProcessNextEvent_P  [mozilla/xpcom/build/nsthreadutils.cpp, line 227]
nsThread::ThreadFunc  [mozilla/xpcom/threads/nsthread.cpp, line 251]
_PR_NativeRunThread  [mozilla/nsprpub/pr/src/threads/combined/pruthr.c, line 458]
MSVCR80.dll + 0x2a45 (0x78132a45)
Assignee: mscott → nobody
Severity: normal → critical
Component: General → XPCOM
Keywords: crash
Product: Thunderbird → Core
QA Contact: general → xpcom
Version: unspecified → Trunk
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

9 years ago
I changed it to worksforme since the issue don't occurs anymore.
You need to log in before you can comment on or make changes to this bug.