Inproper sorting of grouped mails (old mail on the top, started in TB1.5)

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: tomasz.kulig, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 2600 SP2, updated completely

I have used TB since version 1.5. I got such error in thisversion, but I assumed that this error was reported already. But it probably wasn't. Currently I've switched to 2.0.0 EN and problem still exists.

I do not have reproduction schema, but I'll try to give you as many details as possible. If additional information are needed please do not hesitate to ask.

Ok, lets go.

In some rare cases (1 per 30 mail downloads) my mail window looks like as on the attached image. I have seen it only on Inbox folder.
http://kuling.pl/upload/tb2.png

I use sorting mail by date/groups/descending. Threads/all.
When I download some group of mails and some of them are junk, then after junk is moved to to junk-folder I have layout as presented.
Even worse. In 1.5 version I got crash when I clicked on mail below 'Old mail' group. 

When I change folder and back to Inbox folder then all back to normal.

I have 4 accounts. All mails loads in global Inbox. I have some filters which move mail to subfolders of Inbox. In described situation at least one filter has filter out messages. Junk mail also was filtered. As I investigated some junk was send for the same account as filtered messages, some junk was send to another.









Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.



I use addon like in
http://kuling.pl/upload/tb2b.png

I use standard theme.

In previous version I used only 'Minimize to tray' addon.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0
So the problem is that you for some reason get

Old mail
|_ somemail
|_ Yesterday

Someothermail

Last week
|_mail
|_mail2

... though Yesterday should be a group? And all mails should belong in a group.
(Reporter)

Comment 2

12 years ago
Yes, exactly.
There should be 3 groups:

Yesterday
|_somemail
|_somemail
Last week
|_somemail
|_somemail
Old mail
|_somemail
|_somemail

I have 2 problems. "Old mail" folder is listed first, at the top of list of groups, when it should be at the end. 
The second problem is that "Yesterday" group became node/leaf of "Old mail" group when it should be on the same level.

I will try to deeply investigate this problem, but I doubt that I can find any additional information.
(Reporter)

Comment 3

12 years ago
This problem occurred again. This time list of messages looks a bit different.
http://kuling.pl/upload/tb3.png

I got 20 spam messages (10 from current day and 10 from yesterday), all have been filtered correctly. 

But I also noticed that this improper look appeared just after spam messages have been moved. Then new additional message 'Re: Vista problems' which you can see on the attachment was downloaded a bit later.
 
Assignee: mscott → nobody
(Reporter)

Comment 5

10 years ago
I can not confirm this bug in 3.0 beta. Sorry. I don't use beta in my primary work place (I still use use 2.0 version). In secondary work place I use 3.5 beta 4 but I don't remember if I got such problem. 

But answering you question. I've iterate thorough all ticket you have listed and here are matching tickets.

a) This bug looks very similar to me:
https://bugzilla.mozilla.org/show_bug.cgi?id=384564
I also use only POP3. My "Today" group had name "Old Mail" very often when I saw this bug. See previously mentioned http://kuling.pl/upload/tb2.png

b) This bug is also very similar. 
https://bugzilla.mozilla.org/show_bug.cgi?id=444536

I also use similar grouping schema:
"View" -> "Sort by" -> "Date" (descending)
"View" -> "Sort by" -> "Grouped by Sort G"
"View" -> "Threads" -> "All"

This screenshot (from this ticket) looks almost identical as my bug https://bug444536.bugzilla.mozilla.org/attachment.cgi?id=328841

But he uses IMAP. I use POP3 only.

c) I can not confirm them. But I got my problem several times when some messages were classified as spam and moved to Junk folder. Very often spam messages have dates from future. 
https://bugzilla.mozilla.org/show_bug.cgi?id=477536
https://bugzilla.mozilla.org/show_bug.cgi?id=478863

d) This error also gives result as mine error.
Quotation: "List of messages in the message pane corrupts -- sometimes blank list entries will appear, sometimes "Old Mail" header bars will randomly appear in the middle of the list, etc."
https://bugzilla.mozilla.org/show_bug.cgi?id=482673
(Reporter)

Comment 6

10 years ago
Was "In secondary work place I use 3.5 beta 4". Should be "In secondary work place I use 3.0 beta 2".
(Reporter)

Comment 7

10 years ago
I can confirm that this problem can occur also in 3.0b2.
I go this "Old Mail" on the top on my secondary machine. I can not confirm in 100% but it happened when I manually deleted mail from "Today" folder.
See attachment.

http://kuling.pl/upload/20090624.jpg
Tomasz, here using last beta 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2pre) Gecko/20090721 Lightning/1.0pre Shredder/3.0b4pre ID:20090721034342

Tb work fine also when I set "inverse" order as in you screenshot on comment #7.

Can you try with last beta please

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ ?
(Reporter)

Comment 9

9 years ago
I had been using Shredder/3.0b4pre for last month and during this time I didn't noticed even 1 situation reported in this ticket. 

I will inform you if I got any new information.
Ok, thanks Tomasz.

I close this as WFM becasue work fine on TB 3.X (per comment #8 and comment #9) 

(2.X is a security fix and maintainance branch it's very unlikely that what fixed this bug ends up backported to the 2.x branch).

Feel free to reopen it if this issue raise also on TB 3.X
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.