Mail copy between different imap accounts kills all network connections to the target domain

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: carsten.lemmen, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; nl-NL; rv:1.8.1.3) Gecko/20061201 Mozilla compatible
Build Identifier: Thunderbird Version 2 beta 2 (20070116)

I have two imap/smtp accounts, between which I copy mails by dragndrop from one account to the other. Irregularly, the network connection to the target account is lost ("Connection timed out"). However, not only the connection to the imap server imap.targetserver.example and smtp.targetserver.example is lost, but all connections to the entire domain targetserver.example are lost (like sshfs mounts, webdav, ....)

> ping sshserver.targetserver.com 
3 packets transmitted, 0 received, 100% packet loss, time 2008ms

Only after restarting the network 
> sudo /etc/init.d/networking restart

The connection is resumed and everything including smtp/imap to target domain regain functionality



Reproducible: Sometimes

Steps to Reproduce:
Have two imap/smtp accounts (non-ssl)
copy mails from folder in imap.source.example1 to imap.target.example2
Actual Results:  
all network connections to target domain lost

Expected Results:  
connection persisting

Current Ubuntu 7.04 (Feisty Fawn)

> uname -a
Linux ********* 2.6.20-15-386 #2 Sun Apr 15 07:34:00 UTC 2007 i686 GNU/Linux

Assigned critical as it has side effects beyond the TB product

Comment 1

12 years ago
I think this is a problem with your network, not a problem with TB - TB can't cause the side effects you're describing.
(Reporter)

Comment 2

12 years ago
I agree, TB should not be able to cause the breakdown of the network connection.

How can it then be, that reproducibly the network connection breaks down on the copy user action in TB?

Has anyone an idea to track this down and *make sure* it is not a TB caused side-effect?

Comment 3

12 years ago
TB caches connections to the imap server. The connections go bad due to something in your network, and then you notice the bad connections when you do the copy action - the copy action doesn't cause the problem; it just makes it visible.
(Reporter)

Comment 4

12 years ago
Alright, closed as invalid.  Funny that TB can be used to bugstress my system ...
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.