Unable to create Test Plan in Testopia 1.2

RESOLVED FIXED

Status

Testopia
Test Plans
--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Warren Howard, Assigned: Greg Hendricks)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060911 SUSE/1.5.0.7-1.3 Firefox/1.5.0.7
Build Identifier: Bugzilla 2.22.2, Testopia 1.2

Brand new Bugzilla 2.22.2 installation, with Testopia 1.2.  Installation steps proceeded smoothly.

First action after installing Bugzilla and Testopia is to create a new project and a new test plan.

Select "New Plan"
Name : "My acceptance test plan"
Type : "Acceptance"
Product : "My sample product"
Product version : "0.1"

Click the "Add" button on the right and the following error appears :


Internal Error

Bugzilla has suffered an internal error. Please save this page and send it to emailaddress@naturesoft.net with details of what you were doing at the time this message appeared.

URL: http://newbugs.naturesoft.net/tr_new_plan.cgi
undef error - Undefined subroutine &main::Param called at Bugzilla/Util.pm line 408. 

The accompanying log message from the Apache error log is :

[Tue Apr 24 16:03:16 2007] [error] [client 192.168.0.148] [Tue Apr 24 16:03:16 2007] tr_new_plan.cgi: Argument "" isn't numeric in numeric gt (>) at data/template/template/en/default/testopia/plan/navigate.html.tmpl line 23., referer: http://newbugs.naturesoft.net/tr_new_plan.cgi

Reproducible: Always

Steps to Reproduce:
1.Install Bugzilla 2.22.2 and Testopia 1.2 on Linux
2.Create a new test plan
3.



Possibly this is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=377625 but some of the error messages I am seeing appear to be different.
(Reporter)

Updated

11 years ago
Version: unspecified → 1.2

Comment 1

11 years ago
I see "undef error - Undefined subroutine &main::Param called at Bugzilla/Util.pm line 408." as well on a windows installation (WinXP), Bugzilla 2.22.2, Testopia 1.2.
(Assignee)

Comment 2

11 years ago
I am not sure why this is showing up. This is in Bugzilla code. It seems to be called in the template FILTER but why it complains here and not elsewhere is a mystery to me.
(Assignee)

Comment 3

11 years ago
Created attachment 263731 [details] [diff] [review]
Patch to fix error message.
(Assignee)

Comment 4

11 years ago
    Checking in tr_new_plan.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_new_plan.cgi,v  <--  tr_new_plan.cgi
    new revision: 1.13; previous revision: 1.12
    done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

11 years ago
Works for me.

Thanks,


Warren.

Updated

11 years ago
Duplicate of this bug: 380034
You need to log in before you can comment on or make changes to this bug.