Sunbird process doesn't terminate after adding recurring event

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Kensie, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

(Reporter)

Description

12 years ago
So this may just be me, but I've tried several calendars and a new profile.

STR

1. Subscribe to http://steelgryphon.com/testcal/test1.ics test1 test1
2. Create new event, set recurrance to weekly, repeat 5
3. Exit Sunbird and watch processes tab in Task Manager

Results
Sunbird doesn't free up any memory whatsoever.  Reopening sunbird and exiting again makes no difference.

I've reproduced this on latest Trunk and latest branch, on XP sp2.

Comment 1

12 years ago
WFM using icalx.com and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070423 Calendar/0.5pre
(Reporter)

Comment 2

12 years ago
broken for me on icalx.com fun!

Anyone have any ideas on what I should look for to see why it's me?
(Reporter)

Comment 3

12 years ago
I reinstalled branch to a fresh folder and the problem is no longer occuring, looks like something from an old install is interfering.
Sunbird does some magic with delaying the application termination if you shutdown Sunbird while a write operation to server is still active (Bug 328810).

Maybe this is happening here? Maybe the write operation isn't finished properly resulting in Sunbird process waiting forever or the fix from Bug 328810 is not working properly.
(Reporter)

Comment 5

12 years ago
This doesn't seem to be happening for me anymore.  I had to do a system restore for some other issues. I'll report back and mark WFM if this doesn't crop up again.

Comment 6

10 years ago
There have been many issues with recurring events, perhaps this bug has something to do with all of that. However, after reading through some of the code for recurring events - I am stumped. Where else could the code that I am looking for be located?
WFM per comment 5
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.