Do not save form data for https sites

RESOLVED DUPLICATE of bug 190700

Status

()

RESOLVED DUPLICATE of bug 190700
12 years ago
12 years ago

People

(Reporter: stano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Ordering something from an online shop again I noticed that my credit card number was remembered and suggested for the form field.

Generally I want the Firefox to remember form data, but in this case I'd like it to _not_ to save it. I am not quite sure this is the default (my profile is a bit aged), but if it is, it is a bad one.

Suggestion: define saving form data defaults separately for http:// and https:// pages and require an explicit step to turn on the save feature for the latter, preferably with warning that the sensitive data might get saved.

Reproducible: Didn't try
see also enhancement request bug 252486
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 190700
You need to log in before you can comment on or make changes to this bug.