Not allowed to get the lineNumber property of the "Not enough arguments" exception from XPConnect

RESOLVED DUPLICATE of bug 291377

Status

()

Core
XPConnect
RESOLVED DUPLICATE of bug 291377
11 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({testcase})

Trunk
x86
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
javascript:try { document.createExpression("//html:body"); } catch(e) { alert(e.lineNumber) }

Result:
Error: uncaught exception: Permission denied to get property UnnamedClass.lineNumber
(Reporter)

Comment 1

11 years ago
WFM now that bug 291377 is fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 291377
(Reporter)

Comment 2

11 years ago
http://www.squarefree.com/shell/shell.html is now able to show:

NS_ERROR_XPC_NOT_ENOUGH_ARGS on line 1: Not enough arguments [nsIDOMXPathEvaluator.createExpression]

Yay!
You need to log in before you can comment on or make changes to this bug.