Mozilla store uses pictures of text

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
12 years ago
11 years ago

People

(Reporter: db48x, Assigned: jslater)

Tracking

Details

(Reporter)

Description

12 years ago
The mozilla store uses pictures that consist entirely of text, such as this one: https://store.mozilla.org/images/ShipToThisAddress.jpg. Instead it ought to use actual text, that can be rendered according to the user's preferences (including aurally if that's required.)
Assignee: marcia → jslater
Component: Mozilla Store → store.mozilla.org
Product: mozilla.org → Websites
QA Contact: marcia → store-mozilla-org
Version: other → unspecified
(Assignee)

Comment 1

11 years ago
This is performing as intended...we mostly use HTML text in the store, but occasionally use graphic text for design reasons.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
WONTFIX, then, not FIXED.
Resolution: FIXED → WONTFIX
(Reporter)

Comment 3

11 years ago
I'm aware that it was designed that way. It's not as if it could have happened accidentally, or been the result of an unexpected interaction between complex systems. However, you guys could do better. There's no need to limit yourself to the usual low standards of web design when you have the opportunity to make a site that champions both good design and good accessibility. The images don't even have alt text, which is the most basic form of accessibility possible.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
There shouldn't be usage of graphic instead text because it's not accessible for screen readers and therefore users with bad vision won't be able to read this.

Comment 5

11 years ago
Surkov, it's okay to use the graphic as long as there is alt text. Otherwise a11y would always be at odds with graphic artists :)
(In reply to comment #5)
> Surkov, it's okay to use the graphic as long as there is alt text. Otherwise
> a11y would always be at odds with graphic artists :)
> 

Ok. Then there should be @alt for those images per Daniel's comment?

Comment 7

11 years ago
Yes of course, any image that's informational or interactive needs @alt.

If it's decorative it should get alt="" so that screen readers don't try to guess based on the file name and read some horrible programmatic garbage.
(Reporter)

Comment 8

11 years ago
I think it would be preferable to avoid using images that merely contain text in the first place. For one thing, images do not scale up as well on high resolution monitors as plain text does. Of course, since the current font seems to have been chosen with an eye towards making the menus look edgy or grungy rather than readable, it's likely that nobody will care.

Adding alt text to the images is just a way to wallpaper over the real bug.

Comment 9

11 years ago
Using real text also makes it easier to use find in page.

Anyway, thanks for checking on the a11y. FWIW the decision to use alt text vs. real text is more of a design issue than an a11y issue.
(Assignee)

Comment 10

11 years ago
Hi all. Thanks for your comments and opinions. You are absolutely right that the store needs alt tags...we are in the process of gathering a list of fixes to send to the 3rd party vendor that operates the Mozilla Store, and adding alt tags will be one of our top priorities when we make the update.

As for the status of this bug, I'm going to close it again and mark it as "won't fix". Reason being that we're going to keep the graphic text as it is, and the alt tag issue is a separate one that will be addressed outside this particular bug.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.