adding a later before an earlier mail to a new folder breaks threading

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: sschwarzer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070408 Firefox/2.0.0.3
Build Identifier: 1.5.0.10 (20070304)

Assume you have a message 1 and a reply to it, message 2. If you create a new folder and move message 2 and then message 1 to it, sorting by date (ascending) actually shows two threads with message 2 (the reply) before message 1.

In actual use, this showed up like this (and is therefore annoying): When a message is moved by mistake to another folder and then back to the original folder, subsequent threading by date in the original folder lists the message at later times than before (as or near the most current timestamp).

It seems that threading by date or order received depends on the order of the messages in the mailbox.

Reproducible: Always

Steps to Reproduce:
1. Create a new mail folder.
2. Move two messages to the new folder, where the message you select and move first is a (direct?) reply to the message you move second.
3. In the new folder, select threading by ascending date.
Actual Results:  
The reply is shown above the mail it replies to. Irrespective of what you do with the folder, you can't get the messages threaded correctly.

You can "fix" the threading by moving both messages to another folder and moving them back to the new folder with the original message moved before its reply. However, if you don't have a folder with just the two messages, they will be threaded wrongly with respect to other mails which were already in the folder.

Expected Results:  
The order in which messages were moved back and forth previously shouldn't influence the threading at all. The reply should always be shown indented below the message it refers to.

- I have this Thunderbird options set:
mail.strict_threading = true
mail.thread_without_re = false

- The problem occurs with both IMAP (Dovecot 1.0.rc29) and local folders.

- I tried the following workarounds, but to no avail:
-- Selected both messages in Thunderbird, moved them per drag and drop to another new folder and selected them again and moved them together to the first fresh folder.
-- Stopped Thunderbird, deleted msf files, deleted IMAP server's index files, touched later file (the reply) in the appropriate maildir directory, started IMAP server, started Thunderbird.

- The above workaround succeeded when I, additionally, renamed the maildir file for the reply so that it was listed after its parent when using ls. This works but scales very poorly of course when done manually, or would require a program. Moreover, the workaround doesn't influence messages that are moved later, i. e. after the workaround has been applied.

- It seems that the threading depends on the order the mails are stored in and/or retrieved from the maildir or mailbox. It shouldn't depend on that at all.

- I found the behaviour described above also in Thunderbird 2.0.0.0, but I investigated that not as deeply as with Thunderbird 1.5.0.10 (e. g. with respect to the workarounds).

- I looked about two hours for this or duplicate bugs but found nothing similar enough to add my report there.

- Maybe the severity should be "normal" instead of "major", but _for me_, the bug is _very_ annoying.
(Reporter)

Comment 1

12 years ago
Added the Thunderbird version.

I did the above tests only on my Linux box; I don't know if the bug also occurs under other platforms or operation systems.
Version: unspecified → 1.5
Bug 262316 perhaps? Would be fixed, but on trunk only.
(Reporter)

Comment 3

12 years ago
I downloaded the nightly build from http://www.mozilla.org/developer/#builds . The version of Thunderbird available there (2007-04-25) still has the bug described here but it may be that it doesn't contain the patch attached to bug 262316.

I'm also not sure if it's the same bug since the symptom for bug 262316 is that the messages in the thread are in wrong order, whereas for this bug 378727, there is no thread at all.
That build should contain the fix, so this is something else then. Does "rebuild index" in the folder properties help?
(Reporter)

Comment 5

12 years ago
Hello Magnus,

The "rebuild index" button on the new folder seems to resort the messages so that the parent is before the child. However, clicking the thread "buttonlet" (column header with thread symbol) still only indents both messages as if they were distinct threads. Clicking the column header continuously toggles the order of the messages but they still make up two threads instead of one.
Assignee: mscott → nobody

Comment 6

10 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081116 Shredder/3.0b1pre

can you reporoduce this using an early release? http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
(Reporter)

Comment 7

10 years ago
Thanks for getting back. The bug doesn't seem to occur anymore in Shredder 3.0 a3, the newest version I found on the early release download page.
->WORKSFORME per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.