Message content pane is blank

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Michael Mak, Assigned: Bienvenu)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a4pre) Gecko/20070425 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a4pre) Gecko/20070425 Thunderbird/3.0a1 ID:2007042503 [cairo]

After double click on the message, the message window is displayed. However the message content pane is blank.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird
2. Double click on any message
3. Message content pane is blank
Actual Results:  
Message content pane is blank.

Expected Results:  
Message content pane should display the message

For the time being I put down Windows Vista as the effected OS. Can someone please confirm it is effecting XP and other OS too?
(Reporter)

Comment 1

11 years ago
Created attachment 262765 [details]
Blank message pane

The content of the message is:
You can't see any of this at all
(Reporter)

Updated

11 years ago
Component: General → Mail Window Front End
Summary: Message content pane is blank in message window → Message content pane is blank in standalone message window
Version: unspecified → Trunk
(Assignee)

Comment 2

11 years ago
IMAP or POP3? Anything on the error console? Did this just start with today's build? Can you see the message in the 3-pane ui?
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 years ago
version 3.0a1 (20070425)
I'm having this problem as well, and I use an Outlook 2003 IMAP server.  I haven't tested a really wide array of message types, but it seems, so far, like it's just inline HTML messages that do not appear.  I see some plain text messages without difficulty;  At least one multipart/alternative message with plain text does not display plain text even when specifying that plain text should be preferred.

Also, if I am viewing an erroneously empty message pane, and disable "View -> Display Attachments Inline," messages will appear.  It doesn't seem to continuously work for additional messages, but if i turn it back on and then off, the message appears.  

Comment 4

11 years ago
(In reply to comment #2)
> IMAP or POP3?

Here it's with POP3 as well as with news-accounts.

> Anything on the error console?

Totally empty.

> Did this just start with today's
> build?

Definitively, yesterdays build (2007042404) was fine.

> Can you see the message in the 3-pane ui?

Nope. But for mails with an attachment the attachment pane is there.
(Assignee)

Comment 5

11 years ago
Can someone save a message that has this issue as a .eml file, and attach it to this bug, or e-mail it to me? Thx!

Comment 6

11 years ago
I get this randomly for the 3-pane also, both imap and pop on linux. Seems 20070425 is the first build to have it. It's not limited to any particular type (for me), some are plain text some are html - e.g. bugmail shows it. For the 3-pane, clicking another message and then clicking the message again loads it - randomly. 
Keywords: regression
OS: Windows Vista → All

Comment 7

11 years ago
Confirmed for the 3-pane also, this is a regression between 20070424 and 20070425.
(Assignee)

Comment 8

11 years ago
I'm going to need some help reproducing this - I haven't seen it on windows or mac, imap or local messages...

Comment 9

11 years ago
Created attachment 262794 [details]
Oh, and this is not Vista related. I've got XP Pro SP2. Attached eml. Addresses and domains removed to protect the innocents

Comment 10

11 years ago
Oooh. It affects email, newsgroups and RSS message panes as well. Clicking back and forth on other messages workarounds the bug.
(Assignee)

Comment 11

11 years ago
I have no problem reading that message, so I doubt it's anything specific about a message...I'll keep my eye out for the problem...everyone who's seeing this is on Windows? Do any of the folders (or parent folders) involved contain non-ascii characters in their name?

Comment 12

11 years ago
David, I don't think the folder name has nothing to do with it, nor I changed any name of any folder. And no, it's not specific to THAT message as it affects email, newsgroups and RSS messages as well. It's defnitely a regression from yesterday's built, so we shall concentrate on the check ins from yesterday.

Comment 13

11 years ago
Rolling back to 0424 absolutely worked around it for me.  I went back and forth a couple times earlier today, and 0425 breaks most messages, 0424 doesn't.

I was seeing the problem in folders with very boring names, e.g. "inbox", and none of my folders have anything more exotic than spaces (just those, dashes, numerals, underscores, upper and lower case, all in English).  Earlier I mentioned my outlook server, but my second account is on linux dovecot IMAPs and had the same problems.
(Assignee)

Comment 14

11 years ago
er, well, I'm just assuming it my file spec removals that landed last night that caused the issue. But I can't reproduce the problem.

Comment 15

11 years ago
I've reinstalled 0425, and it's getting less weird to me.  There is a definite pattern to whether a message will appear or not.

I don't know what sort of categorization is going on, but there is a categorization, and moving from message to message across the boundaries of this categorization that determines when messages can be seen.  Clicking between messages in the same category lets you see them, and switching categories makes a message fail to appear.  I've been able to move some messages from folder to folder, delete .msf and .sbd files and restart, copy spool files, and these messages maintain whatever characteristics determine this categorization.  I've only tested on one computer though, and I've done nothing more advanced with my tbird installation than switch from 0424 and 0425.  I haven't figured out what the categorization is based on.

I've been able to isolate three groups of messages, but I couldn't say if there are more than that.  I'm working on a way to prepare and label some examples for upload

Beyond that, there are a few things I can do that constitute a "retry", where messages will be displayed.  I suppose it's the same as if clicking the same message twice counted as moving to another message in the same category.
These act like a "retry":
 - Toggle "Display Attachments Inline"
 - Choose a character encoding (any encoding, even what was already selected)
 - Choose "Message Body As" (even what was already selected)
 - Switch to another folder and come back without selecting a message in the other folder=

Comment 16

11 years ago
Created attachment 262817 [details]
a mail spool file with incompatible messages

Comment 17

11 years ago
I will describe the above attachment.

There are 3 classes of message - I flagged messages in the first group. There are two large HTML advertisements from guitar center (actually a duplicate of the same message) that do not behave as predictably, but are the second group. The other unflagged messages are the third group.

I set these flags after determining that they were grouped to each other, and re-tested the spool and the same groupings were present.  I then made a copy and (half-heartedly) anonymized the email addresses, hostnames, and IP addresses, and still the same groupings were evident upon re-testing,

Comment 18

11 years ago
Updating summary to reflect occurrence in three-pane configuration as well.
Summary: Message content pane is blank in standalone message window → Message content pane is blank

Updated

11 years ago
Duplicate of this bug: 378850

Comment 20

11 years ago
My connection is IMAP against Courier Server. But in the local folders or RSS
folders appears the same problem.
(Assignee)

Comment 21

11 years ago
I tried the folder with sample messages on win XP, and I never saw any issues loading any message, no matter which order I clicked on the messages...

Comment 22

11 years ago
The issue is persistent and consistent for me on XP. Switching back and forth between messages several times usually works to get a message to display.

Maybe it has something to do with NTFS vs. FAT file system? I'm on NTFS.

Comment 23

11 years ago
I'm on my other PC today, and it works for me here (can't reproduce bug) , as well. :/
I'm on NTFS on both machines.  If something as low level as filesystem did this, I'd just go mad.
(Assignee)

Comment 24

11 years ago
I'm on NTFS and I don't see the problem - has anyone tried a new profile to see if  it's profile-specific?

Comment 25

11 years ago
I'm on linux and I see/saw it, so i doubt it...

After a quick run with todays nightly (20070426) it seems to have gone away.

Comment 26

11 years ago
Well it's obviously system-dependent in some way, and I was assuming it had a relationship with file handling. The only variability in file handling I could think of between two XP machines is the use of FAT vs. NTFS.

Comment 27

11 years ago
Confirming problem appears to have gone away using today's trunk.

Comment 28

11 years ago
I've tested 0425 and 0426 on both my PCs now (got RDC to the one from yesterday), and in both places, 0425's sick, and 0426 is well.

For the record, I finally find a single thing the grouped messages have in common.  If the header area is the same height for two messages that are viewed consecutively, the latter message will be displayed, but if it changes (e.g. there is a Reply-To in one but not the other), the later message will appear blank.  For my long HTML message that behaved unpredictably, there was an additional "do you want to load images" thingie that popped up while it was drawing the message.

Clicking the "+" to use the condensed header display (it's always the same height) virtually eliminates the problem.

Comment 29

11 years ago
not "popped up", I just mean "was displayed above the header area"

Comment 30

11 years ago
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 31

11 years ago
very interesting - I'm going to mark this WFM since it seems to be fixed in today's build...we can re-open if it re-appears.

Comment 32

11 years ago
WFM as well today. Could the assignee possibly analise what changed in the builds?
(Assignee)

Comment 33

11 years ago
my guess is that something change in the layout code outside mailnews. I no longer think this bug really had anything to do with mailnews code.

Comment 34

11 years ago
I am experiencing what appears to be the same problem.  If I "View -> Message Source", the message is there.  But it appears blank in the message pane.  I tried the workarounds suggested, but none seem to work.  This only happens with occasional messages!  Most messages display fine.  The problem messages also have an attachment listed in the attachment pane labeled "attachment", but when I try to open it, nothing happens.  I'm using "version 2.0.0.6 (20070728)" and when I check for updates, there are none.
You need to log in before you can comment on or make changes to this bug.