Double click + hold on touchpad doesn't work like right mouse click (no context menu)

RESOLVED DUPLICATE of bug 301758

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 301758
12 years ago
12 years ago

People

(Reporter: info, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ru; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ru; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Double click + hold by touchpad doesn't work like right mouse click (no context menu). But it worked well in Firefox 1.x! For example if I double clicked by finger on touchpad and held last finger click for about 2 seconds - context menu appeared (like after right mouse click). If I double clicked + held over a hyperlink - context menu appeared with "open in new tab" option (and other options), that is quite useful when you're working with notebook without mouse.

After installing FF 2.0 this quite useful feature stopped to work. I have PowerBook G4 12''/ Mac Os X 10.4.9 / FF 2.0.0.3

Reproducible: Always

Steps to Reproduce:
1. Get cursor over any hyperlink
2. Double click by finger on notebook's touchpad and hold second finger click for 2-3 secs
Actual Results:  
Nothing apppears

Expected Results:  
Context menu should appear

Comment 1

12 years ago
It was actually click-and-hold, not double-click-and-hold.

This behaviour was removed on purpose in bug 301758, to better fit in the Mac GUI (which uses ctrl-click as an alternative to right-click). Click-and-hold was actually a Netscapism. See bug 301758 attachment 34 [details] for a way to go back to the previous behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301758
You need to log in before you can comment on or make changes to this bug.