[PP]Crash trying to login to cnn custom news, applet invoked

VERIFIED WORKSFORME

Status

()

Core
Plug-ins
P3
critical
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: glynn, Assigned: Patrick C. Beard)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
March 15 optimized Mac build, viewer and apprunner
Works ok on Windows, Linux has other problems getting in the way.

1.  Launch Seamonkey app.
2.  Go to http://www.cnn.com and select "custom news" from the left navigation
frame.
3.  In custom news screen for login name use browsertester, password:  netscape
and hit the login button.

•  Crash into Macsbug, PPC access exception at
NS_NewNameSpaceManager(nsINameSpaceManager**)

sdagley thinks it is invoking plugin code from seeing debug code; there is a java
applet on the custom news page.  Makes sense since same crash can be seen going
to Apple's site, selecting the Star Wars trailer link, then selecting the link to
the 25MB version of the trailer.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

19 years ago
I can't duplicate this problem under the debug build. I will get an optimized
build and see what happens. This is with the tree of 3/18/99 (morning pull).
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

19 years ago
With the 3/18 optimized bits, I can't repeat this crash.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

19 years ago
Reopening...Mac march 18 M3 .2 bits timestamp 7:12pm crash still occurs,
apprunner and viewer.  Will try march 19 builds once posted shortly.  I am
reopening for now.
(Reporter)

Updated

19 years ago
Resolution: WORKSFORME → ---
Summary: Crash trying to login to cnn custom news → Crash trying to login to cnn custom news, applet invoked
(Reporter)

Comment 4

19 years ago
Still crashes, optimized apprunner March 19 build on Mac.  I adjusted the
"browsertester" password "netscape" account to the java applet ticker is invoked
at bottom of the personal news home page, so repro should be no problem; my
oversight as I use my own personal page to test with and forgot to configure test
account in same fashion when I wrote the bug.

Updated

19 years ago
Target Milestone: M4

Comment 5

19 years ago
Setting to M4.

Comment 6

19 years ago
Eli, I'm re-assigning you these Mac bugs to take ownership. These are
Greg's old bugs...
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M4 → M5
(Assignee)

Comment 7

19 years ago
Moved to M5.

Updated

19 years ago
Summary: Crash trying to login to cnn custom news, applet invoked → [PP]Crash trying to login to cnn custom news, applet invoked
(Assignee)

Updated

19 years ago
Target Milestone: M5 → M6
(Assignee)

Comment 8

19 years ago
-> M6
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

19 years ago
Either with or without the MRJ plugin installed, custom news doesn't crash for
me. I can run the applet just fine. There does seem to be a problem clicking in
the applet and getting the browser to go to the applet generated URL. Here's one
of the URLs generated by the applet:

http://customnews.cnn.com/cnews/pna.show_story?p_art_id=3726986&p_section_name=&
p_art_type=1375569

I can manually type in this URL and it works. There must be something wrong with
the nsIPluginManager::GetURL() implementation that keeps this from working under
appRunner. Filed a new bug for this, #6515.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Verified WORKSFORME in 5.17.99 AM builds; specifically, was not able to reproduce
this issue on Mac, Win32 [NT 4] or Linux, upon following the steps to reproduce,
or by playing around a bit within custom news.
You need to log in before you can comment on or make changes to this bug.