Thunderbird totally unresponsive and using 100% CPU after leaving program idle for a while

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Motin / Fredrik, Assigned: Scott MacGregor)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-04-10)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: version 2.0.0.0 (20070326)

After leaving Thunderbird idle for some while, the program goes unresponsive and needs to be killed + restarted to be able to handle mail again

I have two IMAP accounts specified - but with a lot of e-mails in the subfolders and about 20 active filters sorting new mail (as well as the junk mail filter) to appropriate folders. I believe this bug has to do with Thunderbird's IMAP handling. 

This bug is similar to, but not duplicates of:
https://bugzilla.mozilla.org/show_bug.cgi?id=336954
https://bugzilla.mozilla.org/show_bug.cgi?id=320515
https://bugzilla.mozilla.org/show_bug.cgi?id=256493

Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird
2. Leave idle for some while (3-15 minutes)

Actual Results:  
Thunderbird goes unresponsive and needs to be killed + restarted to be able to handle mail again

Expected Results:  
Thunderbird should not go unresponsive like this...

I do not know how to give more relevant information - please provide me with some method for this. 

Attaching a strace to the process shows _nothing_
bug 320515 comment 5 could be of help
(Reporter)

Comment 2

11 years ago
Thanks Tuuka - doing so now. Added an identical comment to some of the similar reports as well. 

PS When I state "This bug is similar to, but not duplicates of", I mean "... as I
know of with current information". It may turn up to be a dupe - but first help
me understand how to decide this...
(Reporter)

Comment 3

11 years ago
Here is the part of the log just before it comes unresponsive:

-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:ProcessCurrentURL: entering
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:ProcessCurrentURL:imap://fredrik%40demomusic%2Enu@mail.minserver.se:143/onlinemove%3EUID%3E/INBOX%3E66141,66142:66154%3E/Auto%20-%20Statistik:  = currentUrl
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:SendData: 1099 uid copy 66141:66154 "Auto - Statistik"
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=89 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: 1099 OK [UID COPYUID 1161177086 5169:5182] Cross-format (unix -> mbxsub) COPY completed
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:SendData: 1100 uid store 66141:66154 +FLAGS (\Deleted \Seen)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1027 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66141)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1028 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66142)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1029 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66143)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1030 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66144)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1031 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66145)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1032 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66146)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1033 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66147)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1034 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66148)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1035 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66149)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1036 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66150)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1037 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66151)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1038 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66152)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1039 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66153)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=57 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: * 1040 FETCH (FLAGS (\Recent \Seen \Deleted) UID 66154)
-1286063216[97ceee0]: ReadNextLine [stream=97cf188 nb=29 needmore=0]
-1286063216[97ceee0]: 97ce420:mail.minserver.se:S-INBOX:CreateNewLineFromSocket: 1100 OK UID STORE completed

I can't really tell if it is relevant, because I don't see the date/time of the log items. It became unresponsive 26 april around 05.10 ...

One strange thing is that a demomusic.nu login is used for the minserver.se server which is wrong and not what I have configured for the minserver.se account (i've got fredrik@minserver.se there...)

Updated

11 years ago
Keywords: hang
Version: unspecified → 2.0

Comment 4

10 years ago
Motin, do you still see the problem? if your issue is not fixed by 2.0.0.9 or newer version, can you try a nightly trunk build? 
Whiteboard: closeme 2008-04-10
(Reporter)

Comment 5

10 years ago
No I don't. However I switched over to gmail which seems to have more decent imap servers (my earlier servers had known problems according to my ISP). 

Closing as WORKSFORME. 

Thanks for your attention.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.