Saving a browser page stops email window from working

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070418 SeaMonkey/1.5a 

While doing a File -> Save As in the browser window, the email window lets
you select different messages in the message list pane, but doesn't update
the message display.  It also doesn't let you close and open the message 
display pane.  

Reproducible: 100%

Steps to reproduce:
1. have a browser window open and a main mail window open, with a mail 
message selected and displayed.
2. In the browser window, visit any text/plain page, then select 
File -> Save Page As in the File menu.  
3. A windows "ssave as" dialog appears.  Don't do anything to it.  Just 
let it sit.
4. go to the mail window.  Select a different message in the mail folder.
Observe that the highlight changes, indicating that the new message is 
selected, but that the mail message display itself doesn't change.
5. You may also try selecting different folders.  You will observe that 
the contents of the message list pane change when a different folder is 
selected, but the contents of the message display pane, including the 
header pane, does not change.
6. Now try to open and shut the message display pane by double clicking 
on that thing in the  middle of the bar that separates the message list 
pane from the message display pane.  The bar changes color, but doesn't
open or close.
7. Go cancel that "Save As" dialog.
8. Now observe that the Mail window works normally again.

Expected behavior:  Saving a web page has NO effect on the Mail window.

Note that, even though clicking or double-ckicking on the bar that separates
the message list pane from the message pane doesn't work, Selecting 
View-> Layout -> Message pane DOES work.  However, I found it necessary to 
click on the word Layout to get the submenu to appear.

Comment 1

11 years ago
Maybe related: Bug 289996
Can you reproduce with SeaMonkey v2.0a1pre ?
(Reporter)

Comment 3

10 years ago
I can not reproduce this with Gecko/2008020302.  I guess this bug got 
fixed during the last 12 months.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.