regression for index() on branches

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
10 years ago
a year ago

People

(Reporter: aaronr, Assigned: aaronr)

Tracking

({fixed1.8.0.12, fixed1.8.1.4})

1.8 Branch
x86
All
fixed1.8.0.12, fixed1.8.1.4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

1.21 KB, application/xhtml+xml
Details
5.89 KB, patch
smaug
: review+
sicking
: review+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
Created attachment 262829 [details]
testcase

The patch for bug 361501 regressed index() on the 1.8 and 1.8.0 branches.  When index() can't find a repeat it is supposed to return NaN.  Which the new xpath worker function triggers by returning -1.  However, the new worker function returns a PRUint32 and not a PRInt32 so the value doesn't look like it is < 0 so we return 0xffffffff instead of NaN.

I can't believe that I missed that when I reviewed.  Ugh!
(Assignee)

Updated

10 years ago
Attachment #262829 - Attachment mime type: text/html → application/xhtml+xml
(Assignee)

Comment 1

10 years ago
Created attachment 262830 [details]
testcase
Attachment #262829 - Attachment is obsolete: true
(Assignee)

Comment 2

10 years ago
Created attachment 262831 [details] [diff] [review]
patch for 1.8 and 1.8.0
Attachment #262831 - Flags: review?(Olli.Pettay)
(Assignee)

Comment 3

10 years ago
Comment on attachment 262831 [details] [diff] [review]
patch for 1.8 and 1.8.0

I fixed this by just switching the PRUint32 to a PRInt32 like it used to be.  Sorry again for missing that on review.

Asking olli to review for xforms, jonas for transformiix so that we can get approval for branch checkin.
Attachment #262831 - Attachment description: patch → patch for 1.8 and 1.8.0
Attachment #262831 - Flags: review?(jonas)
Attachment #262831 - Flags: review?(jonas) → review+

Updated

10 years ago
Attachment #262831 - Flags: review?(Olli.Pettay) → review+
(Assignee)

Comment 4

10 years ago
Comment on attachment 262831 [details] [diff] [review]
patch for 1.8 and 1.8.0

this will correct a regression caused by a function's signature change  mistakenly made in the branch checkin I did for bug 361501.  Affects only the xforms processor since this is an internal interface only used by xforms
Attachment #262831 - Flags: approval1.8.1.4?
Attachment #262831 - Flags: approval1.8.0.12?
Comment on attachment 262831 [details] [diff] [review]
patch for 1.8 and 1.8.0

approved for 1.8.0.12 and 1.8.1.4, a=dveditz for release-drivers
Attachment #262831 - Flags: approval1.8.1.4?
Attachment #262831 - Flags: approval1.8.1.4+
Attachment #262831 - Flags: approval1.8.0.12?
Attachment #262831 - Flags: approval1.8.0.12+
(Assignee)

Comment 6

10 years ago
checked into 1.8 and 1.8.0 branches
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.8.0.12, fixed1.8.1.4
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.