Layout issue: Flash popup adverts obscure website content

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Misha Gale, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-03-08, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

A number of sites have started to use flash advertisments which expand when you mouse over them - there is usually a small banner which becomes a large advert if you move the mouse over. An example is currenty at http://www.newscientist.com/blog/space/ (refresh until you see the Technium advert). However, on my machine the main content of the web page is obscured by a big white box, even if I haven't activated the advert. I'm not a flash expert, but I think that part of the flash movie is supposed to be transparent initially, and FF isn't handling the transparency.

I'm probably not explaining it properly, so here are some screenshots:
http://public.mishagale.fastmail.fm/ffbug_screenshot1
http://public.mishagale.fastmail.fm/ffbug_screenshot2

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.newscientist.com/blog/space/
2. Refresh until you get the Technium advert
Actual Results:  
Annoying white box obscuring website content

Expected Results:  
Unobtrusive banner advert

Comment 1

9 years ago
Do you still see this problem using latest version of Firefox and Flash (10)?

If you do, please comment.
If you do not see the problem, please close the bug - don't use resolution=FIXED, change resolution to:
- INVALID if you believe the problem was flash player
- WORKSFORME if you believe the problem was in Firefox
- INCOMPLETE if it is impossible to test (url or testcase is gone)
Whiteboard: closeme 2009-03-08
(Reporter)

Comment 2

9 years ago
Seems to be working OK with Flash 10 and FF 3.0.5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.