Force en-US as fallback locale if translation for requested one is not available

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Details

At the moment, surfing with non en-US locale is for most people a pain because not few developers use their native locale as the default locale, but many users don't speak this language.
As a result of this, https://addons.mozilla.org/en-US/firefox/user/9480 is very different from https://addons.mozilla.org/de/firefox/user/9480 and you can forget using the search for finding the add-ons in the german locale. A workaround would be to include all locales into the search.

Comment 2

12 years ago
I can see this problem: Falling back to Japanese in the German locale just because there is no German version doesn't seem entirely useful.

Yet, falling back to English might be worse: If people do not fill in the English version, the German version (plus fallback) would be blank.

Also, I don't think including all locales in the search is advisable because it will lead to very confusing results when, say, the Spanish version matches but the German AMO doesn't show that in the results, and instead the results list falls back to English.
I think the solution here is really to tell add-on authors that they should make en-US the default locale unless they have very specific reasons not to, and perhaps move the default locale setting to an "advanced" part of the add-on edit.
Severity: normal → minor
Target Milestone: --- → 3.x (triaged)

Comment 4

11 years ago
@archae, can you provide an example of how this might work for a German user and a potential solution. AMO team couldn't figure out what a technical solution to this might be. Thanks.
Target Milestone: 3.x (triaged) → ---

Comment 5

11 years ago
Here's a request from a user that's related to this:

I use Flock 2.0beta1 and Firefox 3.0.1 as my usual web browsers on
Windows, and they are configured with English [en], French [fr], and
German [de] as content language choices and in that ordering.

When open addons.mozilla.org, the server redirects to SSL and the French
[fr] version of the Addons website
(https://addons.mozilla.org/fr/firefox/): "English [en]" is not recognized
in the language list, even when first in the list. It is only when I put
"English/United States [en-US]" first in the list of languages that
addons.mozilla.org correctly redirects to the English language version
https://addons.mozilla.org/en-US/firefox/ Nor does [en-GB], [en-CA], or
any of the other English language variants except [en-US], redirect to the
English version.

Oddly enough, if the list of languages is English/Canada, French/Canada,
German/Germany, and English/United States (in that order), French/Canada
[fr-CA] is redirecting to the French version (as does French [fr]), but
[en-CA] does not redirect to the English version. Similarly, reordering
that list, I find that both German [de] and German/Germany [de-de]
correctly redirects to the German version of the addons website.

Anyway, perhaps Mozilla could change the server configuration so that
*all* English language variants (English/* [en-*]) as well as English [en]
redirect to the English/United States [en-US] version of the addons
website. It will be less confusing when someone puts a variant of English
first in the browser language list configuration and expects to get the
English language content.

Updated

10 years ago
Duplicate of this bug: 381986
I don't think this is going to be fixed. The per-addon fallback was implemented intentionally to avoid strict fallback and allow add-on authors to decide on their owns what to serve their users.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.