Forward imap messages as attachments misses start of forwarded message body

RESOLVED FIXED

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Forwarding imap messages as attachments doesn't include forwarded message's body - this is a regression from the filespec removal, I'm pretty sure.

Forwarding local messages seems to be fine.
(Assignee)

Comment 1

11 years ago
Actually, this affects local messages as well - the actual bug is that the first couple hundred bytes of the message body seems to be getting skipped...very strange.
Status: NEW → ASSIGNED
Summary: Forward imap messages as attachments doesn't include forwarded message body → Forward imap messages as attachments misses start of forwarded message body
(Assignee)

Comment 2

11 years ago
The bug is here:

http://lxr.mozilla.org/mozilla/source/mailnews/compose/src/nsMsgSendPart.cpp#729

ReadLine reads ahead into a buffer, which throws off the file pointer. So we need to either seek back to where the previous line ended, or somehow figure out how to get the data out of the line buffer. Or, most likely, just stop using the lineinput stream, and use NS_ReadLine directly.
(Assignee)

Comment 3

11 years ago
Created attachment 262917 [details] [diff] [review]
proposed fix

use NS_ReadLine, which lets us know how far off the underlying stream pointer is...
Attachment #262917 - Flags: superreview?(mscott)

Updated

11 years ago
Attachment #262917 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.