Last Comment Bug 378911 - Using Ubuntu, embeded totem does not work with firefox 3 at all
: Using Ubuntu, embeded totem does not work with firefox 3 at all
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Christian Persch (GNOME) (away; not receiving bug mail)
:
Mentors:
: 412333 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 12:15 PDT by ryan
Modified: 2008-07-11 10:50 PDT (History)
12 users (show)
mtschrep: blocking1.9-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
my breakpad, from submitted subfolder of Crash Reports (188 bytes, text/plain)
2008-01-14 13:52 PST, Jakub 'Livio' Rusinek
no flags Details

Description ryan 2007-04-26 12:15:26 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070425 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070425 Minefield/3.0a4pre

It works perfect in firefox 2 but not firefox 3.This is for all videos.

Reproducible: Always

Steps to Reproduce:
1.Go to websites with embeded videos with Ubuntu 7.04 
2.Start a video
3.It will not detect totem
Actual Results:  
It didn't detect totem, and firefox thought it was missing a plugin.

Expected Results:  
Expected result is for the video to start playing.

It works flawless with firefox 2. Not with firefox 3.I'm using the latest nightlies.
Comment 1 Matthias Versen [:Matti] 2007-04-26 14:33:05 PDT
What is totem ?
Is that a video plugin ?

Do you see the plugin in "about:plugins" (as URL) ?
Did you have the plugin in Firefoxs plugin directory ?
Comment 2 ryan 2007-04-26 15:54:35 PDT
http://www.gnome.org/projects/totem/ its the default player and Firefox plugin for ubuntu.

Its listed in about:plugins. It is used to play Windows Media Player Plug-in 10/DivX® Web Player/ QuickTime Plug-in 7.1.3 supported files.

In firefox 2 it plays everything embedded perfectly. In Firefox 3 nothing plays.
Comment 3 Jonas Sicking (:sicking) PTO Until July 5th 2007-05-15 16:05:01 PDT
Has anyone reported this to the totem player team? Seems like they should have a look first.
Comment 4 Jonas Sicking (:sicking) PTO Until July 5th 2007-06-14 15:42:18 PDT
A month has passed since my last comment, what's the latest word here?
Comment 5 Johnny Stenback (:jst, jst@mozilla.com) 2007-07-02 17:14:50 PDT
Minusing. Please re-nominate if there's more input here.
Comment 6 Demare Julien 2007-09-23 10:51:20 PDT
There's still a problem between Firefox and Totem.
With Firefox 3.0a9pre 2007092304, Totem start to play the video but Firefox crashes some seconds after.

I guess that everyone using Gnome, Totem plugin and Firefox 3 can reproduce this bug.
Comment 7 Hideo Oshima 2007-11-03 05:17:00 PDT
How is about:plugins?
Is there "Totem Web Browser Plugin" in the about:plugins page?
Comment 8 jotronic 2007-12-19 14:02:58 PST
I can reproduce the problem with totem. Firefox crashes when a movie at stage6.com is about to be played.

System: xubuntu 7.10 @ AthlonXP 2500+ 768MB Ram
Comment 9 Jonas Sicking (:sicking) PTO Until July 5th 2007-12-31 14:31:23 PST
Can anyone provide more information here? Like a crash stack? Or a breakpad report?

Has anyone talked to the totem people?
Comment 10 Jakub 'Livio' Rusinek 2008-01-14 13:50:29 PST
*** Bug 412333 has been marked as a duplicate of this bug. ***
Comment 11 Jakub 'Livio' Rusinek 2008-01-14 13:52:47 PST
Created attachment 297062 [details]
my breakpad, from submitted subfolder of Crash Reports
Comment 13 Jonas Sicking (:sicking) PTO Until July 5th 2008-01-14 19:23:07 PST
That certainly looks like a bug in our code.

Are other people crashing with the same stack? I.e. more breakpad reports would be great.
Comment 14 Reed Loden [:reed] (use needinfo?) 2008-01-14 19:24:25 PST
Is this just bug 412068?
Comment 15 Jonas Sicking (:sicking) PTO Until July 5th 2008-01-14 19:53:23 PST
Yeah, that stack seems to be. So either this bug is a dupe, or comment 10 and comment 11 aren't really related to this bug.
Comment 16 Jeff Walden [:Waldo] (remove +bmo to email) 2008-01-14 20:07:13 PST
The crash is definitely a dup of bug 412068, but whatever issue was there before probably will still remain when that's fixt.
Comment 17 Jeff Walden [:Waldo] (remove +bmo to email) 2008-01-15 06:07:59 PST
Bug 412068 is fixed, so there shouldn't be a crash any more here (and whatever was wrong before should now be wrong again).
Comment 18 Mike Schroepfer 2008-01-18 12:35:50 PST
(In reply to comment #8)
> I can reproduce the problem with totem. Firefox crashes when a movie at
> stage6.com is about to be played.
> 
> System: xubuntu 7.10 @ AthlonXP 2500+ 768MB Ram
> 

Can you re-test on a recent nightly?
Comment 19 Mike Schroepfer 2008-01-21 18:07:25 PST
Taking off nom list until we confirm this issue
Comment 20 Jonas Sicking (:sicking) PTO Until July 5th 2008-01-22 15:54:05 PST
And again, has anyone contacted the totem folks?
Comment 21 Jakub 'Livio' Rusinek 2008-01-23 05:11:18 PST
Sometimes even Flash causes crash...
Comment 22 Matthias Versen [:Matti] 2008-01-23 13:39:10 PST
what have flash crashes to do with this bug ?
(and they are in most cases a Adobe bug and not our)
Comment 23 Jakub 'Livio' Rusinek 2008-01-23 13:52:59 PST
O rly? Why Flash worked well month ago and crashes today?
Comment 24 Jakub 'Livio' Rusinek 2008-02-01 10:52:46 PST
Ok, bug in GNOME's BZ:
http://bugzilla.gnome.org/show_bug.cgi?id=513744
Comment 25 Jakub 'Livio' Rusinek 2008-02-04 12:35:41 PST
Stack/back trace needed for bug in GNOME's BZ.
PS: From GDB/etc.
Comment 27 timeless 2008-07-11 10:50:01 PDT
*** Bug 412333 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.