The default bug view has changed. See this FAQ.

Using Ubuntu, embeded totem does not work with firefox 3 at all

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: ryan, Assigned: Christian Persch (GNOME) (away; not receiving bug mail))

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070425 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070425 Minefield/3.0a4pre

It works perfect in firefox 2 but not firefox 3.This is for all videos.

Reproducible: Always

Steps to Reproduce:
1.Go to websites with embeded videos with Ubuntu 7.04 
2.Start a video
3.It will not detect totem
Actual Results:  
It didn't detect totem, and firefox thought it was missing a plugin.

Expected Results:  
Expected result is for the video to start playing.

It works flawless with firefox 2. Not with firefox 3.I'm using the latest nightlies.
What is totem ?
Is that a video plugin ?

Do you see the plugin in "about:plugins" (as URL) ?
Did you have the plugin in Firefoxs plugin directory ?
(Reporter)

Comment 2

10 years ago
http://www.gnome.org/projects/totem/ its the default player and Firefox plugin for ubuntu.

Its listed in about:plugins. It is used to play Windows Media Player Plug-in 10/DivX® Web Player/ QuickTime Plug-in 7.1.3 supported files.

In firefox 2 it plays everything embedded perfectly. In Firefox 3 nothing plays.
URL: http
Component: OS Integration → Plug-ins
Keywords: regression
Product: Firefox → Core
QA Contact: os.integration → plugins
Flags: blocking1.9?
Version: unspecified → Trunk
Has anyone reported this to the totem player team? Seems like they should have a look first.
A month has passed since my last comment, what's the latest word here?
Minusing. Please re-nominate if there's more input here.
Flags: blocking1.9? → blocking1.9-

Comment 6

10 years ago
There's still a problem between Firefox and Totem.
With Firefox 3.0a9pre 2007092304, Totem start to play the video but Firefox crashes some seconds after.

I guess that everyone using Gnome, Totem plugin and Firefox 3 can reproduce this bug.

Comment 7

10 years ago
How is about:plugins?
Is there "Totem Web Browser Plugin" in the about:plugins page?

Comment 8

9 years ago
I can reproduce the problem with totem. Firefox crashes when a movie at stage6.com is about to be played.

System: xubuntu 7.10 @ AthlonXP 2500+ 768MB Ram
Can anyone provide more information here? Like a crash stack? Or a breakpad report?

Has anyone talked to the totem people?

Updated

9 years ago
Duplicate of this bug: 412333
Created attachment 297062 [details]
my breakpad, from submitted subfolder of Crash Reports
That is crash ID: bp-9d2fbcb3-c2d5-11dc-844f-001a4bd43ed6

http://crash-stats.mozilla.com/report/index/9d2fbcb3-c2d5-11dc-844f-001a4bd43ed6?date=2008-01-14-19
That certainly looks like a bug in our code.

Are other people crashing with the same stack? I.e. more breakpad reports would be great.
Flags: blocking1.9- → blocking1.9?
Is this just bug 412068?
Yeah, that stack seems to be. So either this bug is a dupe, or comment 10 and comment 11 aren't really related to this bug.
The crash is definitely a dup of bug 412068, but whatever issue was there before probably will still remain when that's fixt.
Bug 412068 is fixed, so there shouldn't be a crash any more here (and whatever was wrong before should now be wrong again).

Comment 18

9 years ago
(In reply to comment #8)
> I can reproduce the problem with totem. Firefox crashes when a movie at
> stage6.com is about to be played.
> 
> System: xubuntu 7.10 @ AthlonXP 2500+ 768MB Ram
> 

Can you re-test on a recent nightly?

Comment 19

9 years ago
Taking off nom list until we confirm this issue
Flags: blocking1.9? → blocking1.9-
And again, has anyone contacted the totem folks?
Sometimes even Flash causes crash...
what have flash crashes to do with this bug ?
(and they are in most cases a Adobe bug and not our)
O rly? Why Flash worked well month ago and crashes today?
Ok, bug in GNOME's BZ:
http://bugzilla.gnome.org/show_bug.cgi?id=513744
Stack/back trace needed for bug in GNOME's BZ.
PS: From GDB/etc.

Comment 26

9 years ago
http://bugzilla.gnome.org/show_bug.cgi?id=520629
Assignee: nobody → chpe

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Duplicate of this bug: 412333
You need to log in before you can comment on or make changes to this bug.