Error in 2.8 README regarding gd.pm

RESOLVED WONTFIX

Status

()

Bugzilla
Documentation
P3
major
RESOLVED WONTFIX
18 years ago
6 years ago

People

(Reporter: Jon Robertson, Assigned: Matthew Barnson)

Tracking

Details

(Reporter)

Description

18 years ago
The 2.8 README says that Bugzilla needs the GD Perl Module version 1.18 OR 
GREATER.  However, later versions of the GD Perl Module require later versions 
of libgd that produce PNG files instead of GIF files.

Not only does Bugzilla not work with PNG files, but RedHat doesn't either.

Assuming I was doing what it took to install Bugzilla, I tried to install gd.pm 
1.27.  In order for this to install, I had to update my libgd and libgddevel 
packages.  Once they were updated, gd.pm 1.27 installed.

However, this caused my RedHat 6.2 system to become unstable and several system 
utils didn't work, including linuxconf.

Someone has already noticed the problem because the Bugzilla 2.9 README 
correctly states to use only gd.pm 1.18 or 1.19.

Please update the 2.8 README.  This cause me two hours of headache.  If it 
weren't that I had a Linux guru available for questions, it would have taken me 
much much longer.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 1

16 years ago
->Bugzilla/Documentation
Component: User → Documentation
Product: Documentation → Bugzilla
-> default owner/qa
Assignee: rudman → barnboy
Status: ASSIGNED → NEW
QA Contact: rudman → matty
Wow, this got buried...

a) we don't fix old versions, that's why we have new ones. :-)
b) Bugzilla does work with PNG files now (and so does RedHat).

WONTFIX
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.