All users were logged out of Bugzilla on October 13th, 2018

Clean up QA contacts for Core components

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: marcia, Assigned: reed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

While working on Bug 378196, I noticed that quite a few Core components are missing nobody@mozilla.org as the default assignee. They instead have a default watch alias as the assignee and no qa contact. Gavin suggests in Bug 37816 that this was probably not done by design. So unless people strongly object, I will align all of the remaining Core components that are missing QA contacts to the convention of being assigned to nobody@mozilla.org and add a QA watch (or repurpose the existing one if one has already been created).

Comment 1

12 years ago
technically it was done by design, we just hadn't settled on the best design.

yes please fix these to match the current design :).

gavin's right in that no one is explicitly relying on the accounts to mean "bugmail from this account indicates this bug is ownerless" instead of "bugmail from this account means this bug is in this component".
Duplicate of this bug: 380446
(Assignee)

Comment 3

12 years ago
Done for the following components under Core:

DOM
DOM to Text Conversion
DOM: Abstract Schemas
DOM: Core
DOM: CSSOM
DOM: Events
DOM: HTML
DOM: Level 0
DOM: Load and Save
DOM: Mozilla Extensions
DOM: Traversal-Range
DOM: Validation
DOM: Views and Formatting
Event Handling
File Handling
GFX
GFX: BeOS
GFX: Win32
HTML: Form Submission
Installer: GRE
Installer: MFCEmbed
Installer: XPInstall Engine
Location Bar
Preferences: Backend
Print Preview
QuickLaunch (AKA turbo mode)
Search
Selection
SVG
Viewer App
Tracking
Web Services
Widget
Widget: Win32
XForms
XML
XSLT

If there was an actual person for the QA contact, that person (with the exception of Hixie and timeless) has been moved to the auto-CC list.

I think this fixes them all. If there's one I missed, please reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Status: RESOLVED → REOPENED
OS: Windows Vista → All
Hardware: PC → All
Resolution: FIXED → ---
(Assignee)

Updated

12 years ago
Assignee: marcia → reed
Status: REOPENED → NEW
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Meaning a component in Core with a "live person" QA or no QA, or any of the components in comment 3 that didn't get done correctly?  

If the former, then

Embedding: ActiveX Wrapper
Embedding: Mac
Form Manager (no QA)
IPC (no QA)
Layout: CTL
Layout: View Rendering
MailNews: BiDi Hebrew & Arabic
MailNews: Palm Sync
MathML
Printing: Xprint
SQL
Talkback Client
Tracking
WebDAV
X-remote
XP Miscellany

I recognize a couple of them as "dead code" components (or, at least dead on the trunk), so maybe we don't want to touch them, but if not, then these need some love yet.
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.