Outline border shines thru DIV layer

RESOLVED DUPLICATE of bug 328296

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 328296
11 years ago
11 years ago

People

(Reporter: Rene Trost, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; de-de) AppleWebKit/419 (KHTML, like Gecko) Safari/419.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a4pre) Gecko/20070426 Minefield/3.0a4pre

An CSS attached outline border of any element stays on top of overlayed layers or shines thru layers with opacity. 

Reproducible: Always

Steps to Reproduce:
See sample page
Actual Results:  
Outline borders are rendered on top of any layer

Expected Results:  
Outline border should be covered by an overlayed element.
(Reporter)

Comment 1

11 years ago
Created attachment 262970 [details]
Screen outline border stays over DIV layer

The outline border should be dimmed by the overlaying DIV (opacity 0.7) but that doesn't happen.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Updated

11 years ago
OS: Mac OS X → All
Hardware: Macintosh → All
Whiteboard: DUPEME

Comment 2

11 years ago
Confirmed on Linux builds since
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1
up to
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a5pre) Gecko/20070430 Minefield/3.0a5pre
May be a duplicate.

Comment 3

11 years ago
confirmed on branch as well with 2.0.0.4 rc3 on Windows
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> Core::General.

This belongs in Core::Layout but it needs a testcase attached to the bug before it goes there.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Whiteboard: DUPEME → DUPEME [needs-testcase]

Comment 5

11 years ago
Created attachment 265717 [details]
Simplified testcase

Here's a simplified testcase based on the one in the URL.

Updated

11 years ago
Attachment #265717 - Attachment mime type: text/plain → text/html

Comment 6

11 years ago
It turns out that the same thing happens if you use a <div> (instead of a <input> button). I think this is INVALID, though.

From http://www.w3.org/TR/CSS21/ui.html#propdef-outline:

"The outline created with the outline properties is drawn "over" a box, i.e., the outline is always on top, and doesn't influence the position or size of the box, or of any other boxes."

If this is the case, then it would make sense that it's not made opaque since it's drawn "over" the opaque <div>.
Component: General → Style System (CSS)
QA Contact: general → style-system
Whiteboard: DUPEME [needs-testcase]
Whiteboard: DUPEME

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 328296
You need to log in before you can comment on or make changes to this bug.