Unable to launch with Installed build

VERIFIED FIXED in M17

Status

P2
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: agracebush, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
build 2000-05-02-08M16 mozilla build only- installer using installer (does not 
happen with regular mozilla*.gz file

./mozilla -installer will launch and migrate profile on first run only
if profiles from previous test exist, ./mozilla will launch profile manager 
allowing for testing

second run with/without an option will generate the following 
message:
error in loading shared libraries: 
/u/gbush/BETA2/502moz/components/libtimer_gtk.so: undefined symbol: 
g_timeout_add_full

some load errors during installation ( I will redo to capture)
(Assignee)

Comment 1

19 years ago
We are being bitten by the classic packager-manifest-wasn't-updated problem.  

Grace,
Can you do a diff on the bits installed by the istaller versus those untarred?  
Please attach the diff if it reveals meaningful results.  Thanks.

Bhuvan,
Since this is a profile issue you may help us by verifying that all libs you'll 
link to on unix are in the mozilla/xpinstall/packager/packages-unix manifest.  
Thanks.
Status: NEW → ASSIGNED
Summary: Unable to launch a second time → Unable to launch a second time
Target Milestone: --- → M17

Comment 2

19 years ago
samir,

I have added libactivation.so and activation.xpt recently to packages-unix file.
Do I need to add all shared objects that libactivation.so might need ? 

This problem is not reported onother platforms...does that mean those packager 
files already have all required libraries mentioned in the respective packages-* 
files ?

Comment 3

19 years ago
any file that is in dist that you want to ship has to be in the 
packages-{platform} file.  This includes any files that a file relies on, or 
files that a library is dynamically linked against if they are not already 
listed in the packages-* file.

Basically, any file you add to the build that is required to run has to be in 
the packages file.

Comment 4

19 years ago
I have added activation files to the packages-* files under ns (where it 
actually belongs..).

This problem is encountered with mozilla builds only (as per grace's 
comments). There is nothing new I have added on mozilla front from profiles 
side...? Is it possible to find out who is calling this libtimer_gtk.so ?

Comment 5

19 years ago
depending on bug 36781
we think due to the crash at the end of linux install, lauching the second time 
might be screwed.
Depends on: 36781
Keywords: nsbeta2
(Assignee)

Comment 6

19 years ago
No.  This has nothing to do with the installer crash.  This has to do with the 
"mozilla -install" flag.  Removing dependency.

The installer crash is completely harmless.  Installation takes place perfectly 
based on XPInstall callback status.  It is a resource/thread issue that causes 
the seg fault on exit.

Since this is related to the "-install" flag I am reassigning to Bhuvan for 
further investigation since it is obviously a packaging issue given Grace's 
original comments.  Bhuvan, please hand off to the appropriate owner if you have 
not implemented the "-install" flag.  Thanks.
Assignee: sgehani → racham
Status: ASSIGNED → NEW
No longer depends on: 36781
(Reporter)

Comment 7

19 years ago
Created attachment 8519 [details]
diffs between gunzip and install bits

Comment 8

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Reporter)

Comment 9

19 years ago
I am not sure if this new behavior is part of this bug or not- installation 
takes place as here- core dump, but now seamonkey does not launch at all.

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 10

19 years ago
changed summary line, adding dependency
Depends on: 38603
Summary: Unable to launch a second time → Unable to launch with Installed build

Comment 11

19 years ago
Good to see bug 38603 getting fixed. Bug 37900 (current bug) would have been
related to those missing files in the packages file too. That's my first guess.
If that is right..I am going to close this bug as a dup of 38603.

If not, I will look for the behavioral symptoms to see if the -installer or any
other profile manager functions are failing at any point....

Comment 12

19 years ago
I tried installer builds. App failed to load some so files. Samir told me that 
tomorrow's build might be better. I tried to install xpi files from 
ftp://sweetlou/products/client/5.0x/unix/linux/2.2/x86/2000-06-02-08-M16/mozilla
-xpi/. It didn't do any good in launching the browser. I can use the 
regular mozilla.tar.gz without any problems. Mystery continues.....
Will check the status with tomorrow's build. Adding samir to cc list.

Changing priority to P2.
Priority: P3 → P2
(Assignee)

Comment 13

19 years ago
Grace,
Now that Cathleen et. al. modified the packages manifest, can you redo the diff 
of installed versus tarball?  Posting as an attachment to this bug works well.  
Thanks.

Bhuvan, 
Is your stack or are your symptoms different from what Grace initially reported?    
Also, once Grace attaches the new diff does adding any of these libs help 
eliminate the problem?
(Reporter)

Comment 14

19 years ago
using build 2000-06-05-08
Installer finishes after the following two lines on console:
nCl registerring deferred
illegal instruction (core dumped)

Installer itself got to 165/165 of mail installed (end?) when this message 
appeared. 
(Reporter)

Comment 15

19 years ago
Created attachment 9639 [details]
errors on console when launching installed build
(Reporter)

Comment 16

19 years ago
Created attachment 9640 [details]
diff of mozilla installer files and mozilla files- June5
(Assignee)

Comment 17

19 years ago
packages-unix problem: some psmglue related libs were missing.  Taking bug and 
fixing.  Missing from bin in the installed bits were:
(*) libcmt.so
(*) libgtkxtbin.so
(*) libprotocol.so
Assignee: racham → sgehani
Status: ASSIGNED → NEW
(Assignee)

Comment 18

19 years ago
Grace, thanks for helping narrow this down.  Now fixed.  Should show up in next 
build.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

18 years ago
build 2000060608
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.