Using JAWS, Firefox terminates unexpectedly when XUL receives focus.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: aaronlev)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 (CK-IBM) Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070427 Minefield/3.0a4pre

While running JAWS, focus to any browser chrome causes the process to terminate.  I do not see the same behavior while running Window-Eyes.  I can start the latest minefield without JAWS, and tab around the HTML content, but the application will terminate as soon as I tab to the URL/address field.

Reproducible: Always

Steps to Reproduce:
1. Start JAWS
2. Launch Firefox with either 'firefox -p' or 'firefox -safe-mode'

Actual Results:  
Dialog flashes on screen and Firefox terminates immediately.


As noted, this happens for any chrome content, so Firefox can be launched normally ('firefox') and still create the problem.  The 'firefox -p' and 'firefox -safe-mode' commands are just the fastest way to reproduce the problem.  

I am using JAWS 8.0.1177U.
(Assignee)

Updated

12 years ago
Keywords: access
(Reporter)

Comment 1

12 years ago
I upgraded to:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070502 Minefield/3.0a5pre
And still saw this problem (but didn't with FF2)

Today, I upgraded JAWS to the latest (8.0.2107U), and the problem no longer occurs.

So, I suspect JAWS was doing something that Minefield didn't like, and FF2 had better error recovery?
(Assignee)

Comment 2

12 years ago
Really hard to say. We shouldn't crash, I can say that.
(Assignee)

Comment 3

11 years ago
This sounds exactly like IAccessible2 mismatch. Since newer versions of JAWS don't cause it, I think they upgraded their IA2 idl and we are in sync again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.