submenu positioned off-screen on non-top-aligned secondary monitor

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Jim Newsham, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2009-09-09][DUPEME])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I'm using a dual monitor system and my primary and secondary screens are bottom-aligned.  For example, my secondary monitor has a larger resolution than the primary, and they are arranged such that the bottom of the screens align on the same Y coordinate, and the top of the secondary monitor has a smaller Y coordinate than the top of the primary monitor (with Y increasing downwards).  Something like the following picture:

     [   ]
[ 1 ][ 2 ]

When accessing my Bookmarks menu which is too tall to fit on the screen at once, on the secondary screen, and scrolling to the bottom of the list, and opening a submenu which appears near the bottom of the screen, the submenu opens at the wrong position:  the submenu is positioned too low on the screen such that it is partially or almost entirely off the bottom of the screen.

Normally, the top of a submenu is aligned with the submenu's parent menu item.  If a submenu would be too low to be completely visible, it will be moved upwards (by some offset Y) such that its bottom is aligned with the bottom of the screen, and its top is above the parent menu item.  But in this case, the submenu is moving *down* so that the top of the menu is below the parent menu item (perhaps by an equal amount, but in the wrong direction: -Y?).

I confirmed that this doesn't happen for me if I align the tops of the screens rather than the bottoms.

Reproducible: Always

Steps to Reproduce:
1.  Buy a dual screen Windows XP system.
2.  Configure the secondary screen to be larger than the first.
3.  Align the screens along their bottom edge (In my case, the secondary monitor is to the right of the primary, and the top edge is slightly higher, while the bottom edges line up).
4.  Have a lot of bookmarks with some hierarchical entries near the bottom.
5.  Scroll to the bottom of your bookmarks and open hierarchical entries (submenus) near the bottom of the screen.
Actual Results:  
Submenus appear positioned incorrectly; they are offset vertically in the wrong direction to compensate for the bottom of the screen.  As a result, they are partially or almost entirely off-screen.

Expected Results:  
Display submenus on-screen where they have their greatest utility.
Whiteboard: DUPEME
Still a problem with Firefox 3.5.2?
Whiteboard: DUPEME → [closeme 2009-09-09][DUPEME]
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

9 years ago
I'm the original reporter.

I haven't used this particular hardware configuration in a while, but I just hooked it up to re-test this issue.  Using 3.5.2, this now works fine/correctly for me.  Feel free to close this issue.  Thank you.
Thanks for your answer Jim! If you should ever see it again feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.